Jekyll Generating but not doing anything

I am starting Jekyll build but it is not ever finishing. On Windows.

>jekyll b
Configuration file: none
            Source: D:/All-SIL/_Jobs/Jobs-2022/2022-04/GPS-Sinama-dict/test
       Destination: D:/All-SIL/_Jobs/Jobs-2022/2022-04/GPS-Sinama-dict/test/_site
 Incremental build: disabled. Enable with --incremental

I have rebooted.
I have reinstalled Jekyll
Still the Generating… is stuck. It never finishes. No files created.
I have tried a simpler build. Same result.

What could it be?

what is inside the source folder? is it a repo you can share? if not maybe a screenshot of it to see what is in it.

try jekyll b --verbose and see if it gives you anything more.

is it the same if you do jekyll serve?

@rdyar Sorry for the delay I’m at a conference with little spare time.

I have another project and it builds fine.

It is the same with jekyll serve and also the same with jekyll b --trace

I removed the new files and the previous files build fine.

So the new files are named and the _includes lex-1.html. The range goes up to

So I am testing by removing files.

It seems to be one of the files between and is causing is an issue. They were all generated by a XSLT2 transforms so should not have any encoding issues and are all almost the same.

The file name may be the issue.

I don’t have time to investigate more just now.

What’s that:

Configuration file: none