Jekyll Serve Not working again

I tried copying a second Jekyll folder on my computer. I am on Windows 10 Pro.
I tried to run bundle update && bundle exec jekyll serve on the new folder/directory hosting jekyll website but now the command prompt just runs through all the commands and then goes back to the command prompt. I tried also updating gem and jekyll commands still the same issue.

what if you just do jekyll serve?

Same issue see screenshot if I just use jekyll serve.


Have you tried the advice the error gives by prepending Jekyll commands with bundle exec?

bundle exec jekyll build
bundle exec jekyll serve

@ark There is an issue with the latest ffi gem (v1.13.0) on Windows.
Please follow the steps below to proceed:

  • Edit your Gemfile by adding the following line:
    # Temporarily lock ffi gem to v1.12.x on Windows
    platforms :mswin, :mingw, :x64_mingw do
      gem "ffi", "~> 1.12.2"
  • Delete existing Gemfile.lock
  • Run bundle exec jekyll serve
1 Like

I could kiss you. FFI 1.13.0 was released yesterday. Coincidentally, I’ve been struggling to figure out why my build chain randomly ceased functioning around lunchtime yesterday. I tried this on a whim and now everything functions as it should.

For me the problem was made manifest really quietly. Jekyll generates all the files, but never actually writes them to the disk. It doesn’t even create a _site directory.

Thanks guys it works, awesome :grinning:
I also tried without adding the code lines to the Gemfile.lock, it seems it might work by just deleting the Gemfile.lock and then running bundle exec jekyll serve.