Updating Jekyll to 3.6 - everything fails


Hello there,

I’m kinda new to Jekyll and static site building but to be honest it’s going totally nowhere. It’s so difficult to make Jekyll pet friendly. I’m almost at this point where I would rather stick a fork in my eye instead of keep using Google for every move I make inside Jekyll and only find search results from 2014.

Today I read on the official Jekyll site there’s an update. Version 3.6 has been released so I try to update, right.

I open my Terminal > navigate to my site folder by doing the: cd / bla bla command. Then I run the command

jekyll --version

To check what version is currently installed. It tells me I have version 3.5.2 installed. So I type:

gem update jekyll

Inside Terminal you can see it’s updating or doing its thing. When everything is done processing I try to run my easy to remember command.

jekyll serve

To fire up Jekyll locally and start building again but I get this error telling me it can’t because I have Jekyll 3.6 installed but my Gemfile requires 3.5.2.

Error log:

You have already activated Jekyll 3.6.0, but your Gemfile requires Jekyll 3.5.2. Prepending ‘bundle exec’ to your command may solve this.

So why is this happening?
I don’t want to type: bundle exec jeykll serve every time I have to start Jekyll from now on forward. I want my simple command back. Just jekyll serve

This is annoying, I have tried to run bundle update and gem install bundler and whatnot. But nothing seems to work. Why hasn’t my Gemfile updated to Jekyll version 3.6 after the jekyll update command.


What does your Gemfile contain?
if it says,

gem "jekyll", "3.5.2"

then simply change it into:

gem "jekyll", "~> 3.6"

This will force Ruby to use Jekyll 3.6.0 at the same time allow you to use future versions…
Then simply run

$ bundle update


Thank you…

This was indeed the problem and fixed it.