Unlock bundle from jekyll version

I get the following error:

$ bundle
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
You have requested:
  jekyll ~> 3.8.5

The bundle currently has jekyll locked at 4.0.0.
Try running `bundle update jekyll`

If you are updating multiple gems in your Gemfile at once,
try passing them all to `bundle update

I am having some weird error having to to with githubpages discussed here:

(and perhaps here: https://github.com/github/pages-gem/issues/555)

any idea how to fix this?

I am currently trying to downgrade my jekyll version.


solution: delete the Gem.lock file


may I know how do you downgraded your jekyll? I am facing similar issues and not sure which steps I should take.

Use a Gemfile and specify the version of Jekyll you wish to use with your site.


gem "jekyll", "~> 3.8.6"

Then run bundle update and prepend all Jekyll commands with bundle exec e.g. bundle exec jekyll build


cool thanks. By the way, why I can’t find _sass file and other folders when I start a new jekyll directory?

That’s because they’re bundled away in the theme gem that Jekyll installs by default… Minima.

Do you know if it is fine to copy and paste those files into my jekyll directory into to edit my theme or update the css file? Because I am having trouble to understand how to use the layouts files and other files as well. Please let me know.

Yeah that’s fine. jekyll new defaults to installing the gem-based Minima theme, which obfuscates all of the _layouts, _includes, and _sass folders.

There are other Jekyll new commands that can scaffold out a site without the theme gem, which is closer to how it used to work before theme gems were a thing.

jekyll new PATH --blank
1 Like