Updating jekyll to the very latest commits


How its possible? I want to use collections inside directory feature but it seems its not in the latest release. And I’m not sure if the next release is coming out soon.


If you’re using a Gemfile it’s pretty easy.

Just replace gem 'jekyll' with the following:

gem 'jekyll', :git => 'https://github.com/jekyll/jekyll.git'

Then run bundle update. It will use whatever is current on Jekyll’s master branch.


Thank you very much. I run bundle update but it gave me the following warning:

Your user account isn't allowed to install to the system RubyGems.
  You can cancel this installation and run:

      bundle install --path vendor/bundle

  to install the gems into ./vendor/bundle/, or you can enter your password
  and install the bundled gems to RubyGems using sudo.


Then as suggested, I run bundle install --path vendor/bundle

Now I’m facing with the following error:

Your Gemfile has no gem server sources. If you need gems that are not already on
your machine, add a line like this to your Gemfile:
source 'https://rubygems.org'
Bundler could not find compatible versions for gem "colorator":
  In Gemfile:
    jekyll-contentblocks was resolved to 1.2.0, which depends on
      jekyll was resolved to 3.6.0, which depends on
        colorator (~> 1.0)

Could not find gem 'colorator (~> 1.0)', which is required by gem 'jekyll', in
any of the sources.

at this point I dont know what to do.


What’s your Gemfile look like?


Now its like this, as you suggested to add that line:

gem 'jekyll-postfiles'
gem 'jekyll-contentblocks'
gem 'jekyll-paginate'
gem 'jalalidate'
gem 'html-proofer'
gem 'fastimage'
gem 'jekyll', :git => 'https://github.com/jekyll/jekyll.git'


Ah that’s the problem. You’re missing a line. The error you included before tells you that. Add this before the other lines and try bundle update again.

source 'https://rubygems.org'


I’m facing another challenge now. when I run bundle bundle install a new folder named vendor is created inside my jekyll website and it seems all gems are installed inside it. I Removed this folder and went to the root folder of my PC and tried to install again. Now if I run jekyll, I receive an error that some gem file aren’t installed.

What am I doing wrong here?


I solved this error by running bundle install --path ~/vendor/bundle inside my jekyll website root.

However now I dont know if I’m using the very latest commits. my jekyll version still shows 3.6.0 and It seems I’m not able to use collections inside directory feature .


It’ll still show 3.6.0 since thats the latest releases version. You can verify if you’re using the latest master by looking at Gemfile.lock

Also make sure you run all Jekyll commands with bundle exec or else it won’t use the right version.

bundle exec jekyll serve


Thank you very much. It did the trick