hi jekyll land,
i’m new to jekyll (and ruby), i’ve set it up locally on a debian machine to build a website that i’ll then push to a vps.
the problems i keep encountering is that after i download a theme (eg a zip from github) to set up my site, they often have dependency problems and wont run. i often get messages like this when i try to run bundle install in the theme dir:
"Bundler could not find compatible versions for gem "bundler": In Gemfile: bundler (~> 1.15) Current Bundler version: bundler (2.0.2) This Gemfile requires a different version of Bundler. Perhaps you need to update Bundler by running `gem install bundler`? Could not find gem 'bundler (~> 1.15)' in any of the relevant sources: the local ruby installation"
and if i eg install the older bundler, then i end up with tons of duplicated gems, because the older versions are also added.
i had this happen on a few older themes so i thought they were broken, but then i just tried with the textlog theme which is not very old (https://github.com/heiswayi/textlog). it also happened with the hack-css theme. the gemfile.lock of hack-css declares that it was bundled with bundler 1.13.x. does that mean that the only way to use that theme is to downgrade bundler (+all dependencies)?
it’s got me thinking that it’s me going about things the wrong way. i’m able to set up a site correctly with the minima and jekyll-now and minimal-mistakes themes, by following the jekyll tutorials. but i didn’t want to go with any of those.
and if different themes require different versions of lots of gems, it seems like it would make changing themes a difficult business.
if anyone can enlighten me a little about any of this, i’d be grateful.