Problem in downloading Jekyll

I’m facing an issue while executing the following command:
bundle exec jekyll serve
I tried a lot to rectify it but coudn’t do. Please help me out with the issue!

Please provide more info.

What is your OS?

What commands did you run? And what error did you get when installing if at all or when running?

Can you share a link to the guide on the Jekyll site you used? E.g. the Windows install flow

For Linux and Mac I have this guide I wrote

A lot of people have issues with getting jekyll working the first time. Check the related questions and answers in the forum to see what they did. Maybe your PATH is not setup or you’re missing a dependency

Yeah! I was installing it on linux.
I followed up these commands

git clone
cd Interactive-Book
sudo gem install jekyll
sudo gem install bundle
bundle install
bundle exec jekyll serve

Before it I installed all the prerequisites.
All other commands executed well but when I run up bundle exec jekyll serve, my process just stops executing the following way:

You can check it out, in the mean time I’ll try to install it by the guide that you suggested.

You can check out this link.

Also there is another error, what should I do to remove it?

Thanks I’ll check those out.

Avoid using sudo when installing jekyll or bundler.

Use the --user-install flag on your last commands as per my guide and you can do gem install without the permission error

Okay I’ll try doing so.

I run up bundle exec jekyll serve, my process just stops executing the following way

All the error logs you added are weird.

But you still got to server running. What happens when you then open localhost:4000 ?

When you visit it the request should show in the terminal

Hey, I got the problem. I’m getting this warning: You don’t have /home/acer/.gem/ruby/2.7.0/bin in your PATH,
gem executables will not run.
That’s why it’s not getting executed. In this case, what should I do?

Add this to .bashrc or .zshrc file


then start new terminal

Check it worked

echo $PATH

Then bundle exec etc.

Okay!! I’ll try doing that.

Sorry my formatting was bad so it hid the first line. See my updated comment above