Jekyll won't start anymore - what does this mean

I can’t figure out what this mean. How do I fix this?

What happend to this support forum. It’s not secure anymore?


what is the rest of the contents of the log? not enough there really.
How are you running jekyll? with bundler?

have you tried:
gem install jekyll bundler

and then
bundle exec jekyll serve

I don’t think the forum was ever secure, it is just more noticeable that it is not.

I think I had multiple versions of Ruby installed and I wasn’t linked correct - or something.

Last time I checked I noticed a Ruby update on the official site so I’m all about working with the latest version and tried to update Ruby on my system but when you don’t know the commands how to do this you start to Google and people say use this, do that … so you end up installing Ruby via RVM and it wasn’t linked or something.

I removed RVM and the entire list of Rubies. Then I updated Brew (was also installed) and linked my computer to the latest version of Ruby, which already was installed. !?! crazy right.

After that > bundle update on my Jekyll project folder and now I’m up and running again.

To be honest, I think the Jekyll docs could benefit from an entry level write down about how to get started with all this. It’s very intimidated for starters and the Command Line doesn’t help in the use of use part.

Thanks anyway.

@Shmoo The steps are very simple IMO:

  1. Ensure you have a recent version of Ruby installed on your system:
    ruby -v
    # returned value should not be lesser than `2.1.0`
  2. Ensure you have jekyll and bundler gems installed or install them by running
    jekyll --version
    bundle --version
    Otherwise, install them by running:
    gem install jekyll bundler
  3. Create a new Jekyll project directory at path ./my_blog by running:
    jekyll new my_blog
  4. Change directory into the Jekyll project folder you just generated:
    cd my_blog
  5. Serve your site to preview it at http://localhost:4000
    bundle exec jekyll serve