Windows 10 Jekyll pages breaks after git init

I am new to git Jekyll and GitHub so sorry if I’m in the wrong place. Haven’t found an answer anywhere yet.

I can create a local site on my windows 10 machine. It serves and runs fine. If I then do a get init and push it to GitHub pages the site now works online, but my local site is broken. I broke it says page not found and the theme is broken as well.

Am I missing a step. What did git init do that would break my local instance?

how do you know the theme is broken if the page is not found?

kind of sounds like you put a baseurl value in for the GH hosting and you aren’t using the proper url locally?

what is your repo? is it a project or your username kind?

Well I guess the Theme being broken might be a wrong statement. It might be due to pages not loading that it doesn’t know the proper info to show. The colors are off but the general format is there.

I am using the Jekyll Doc Theme 6.0.

so this is what I developed localy and works fine on my localhost:4000

And it works properly on

The problem is after I develop locally and do a git init and push it to my page my local instance breaks like so.

I hope this helps explain it.

It might be a Windows only issue, I tried something similar on my linux box and it didn’t break. But I would rather work on my desktop PC.

Worst case I could write some scripts that copy files back and forth if I can find what is breaking. I have pushed to github pages twice. Both times broke my local work. To get it working the second time I basically had to wipe everything and start fresh.

Second image since I could only add a single image to a post

Ok, did a quick test after you pointed me to the baseurl. And i think it worked. So basically when I develop locally I need to set the baseurl to nothing. But when I push it I need to adjust it for github pages.

I will do some testing later to see if this is correct or if I can just leave them both to nothing.

that is the way it used to be, then they made some new url things and if you do it right you no longer need to do that. Your theme probably does not use the new url variables so it is starting off at the root when it really should be at the baseurl.

The way to get around this used to be to have 2 config files - the 2nd one being for local/dev and it would only have baseurl: set to nothing, this would override the actual baseurl in the main config. Then when running locally you would change your command to include both(?) configs with the dev one second. Sounds complicated but it was pretty easy.

Some info on the relative.url and absolute_url variables here: