Jekyll site works locally but not on Github Pages

As the title implies, when I build the Jekyll theme locally using bundel exec jekyll serve my website all loads fine on, but when I commit and push to my github repository upon opening I am met with the following:


I have forked my theme from the following repository: GitHub - mmistakes/jekyll-theme-basically-basic: Your new Jekyll default theme..

I have tried commenting out my baseurl out by doing #baseurl: "" in the _config.yml file to no avail. Here is my repository: GitHub - 420Ayan420/ Website used to store blog, portfolio, etc. Powered by Jekyll and Github Pages..

Many thanks in advance for any other pairs of eyes that may happen to look upon my issue.

can you remove the cname file until you get it to work?

are you sure it isn’t giving you an error somewhere along the line?

are you using the example or docs folders? I’d remove them if not as they look to have their own jekyll sites within them.

I’ve removed the CNAME file and the custom domain setting in the github pages settings.

If by giving me an error somewhere along the line you mean that if my custom domain registry isn’t giving an error, I don’t think it is as before I created a simple github page with just a file and used that to create a github page and it all loaded and updated fine on my custom domain name.

I have also removed the docs folder and the example folder.

I’ll have a look now to see if the issue is resolved after allowing github pages to update for 5-10 minutes.

I am unsure if this has any significance:

As even after deleting the docs and example folders I still have a /docs option. However, I don’t believe this is an issue as even before deleting the folders I had already configured github pages to read from /root.

Second image:

I’ve also noted a strange behavior now, even when I have removed the CNAME and changed my github repository settings still forwards to

Perhaps I should update me DNS server registration for now to remove the github pages from my records?

I don’t think your DNS matters at this point - the GH DNS is still redirecting to it, you need that to stop which maybe takes some time.

Your settings look good.

I’m not sure what is going on but the cname thing is making it harder to tell. Once that clears maybe it will make sense.

As for errors I mean GH build errors. It seems like it built fine.

Yeah building locally is fine for me, I can send a log of the terminal if need be.

fine locally and fine on GH are 2 very different things in my experience, though if you are not using any plugins it is a lot simpler.

This is your problem I think - under Actions you have lots of deployment errors:

your gemfile is specifying jekyll 4 but GH pages uses 3.9 or something. I thought GH ignored the gemfile.

Also not sure why the actions page is there, I didn’t see an action file/folder in your repo. Maybe all GH pages sites use actions now? though that seems weird, with an action you can get past the GH 3.9 limitation so it is like there is a mix of things happening.

I don’t use GH page or actions so I am not all that familiar with it. You could try removing the gemfile and see what happens.

I think that due to the errors the change to the cname file is not being taken into account - so it is still redirecting cause it thought it worked that one time and until you can get past the error it will stay there? something like that.

I think the two errors I am able to see are:

Configuration file: /github/workspace/./_config.yml
60 Theme: jekyll-theme-basically-basic
[61] (pages build and deployment · 420Ayan420/ · GitHub)github-pages 228 | Error: The jekyll-theme-basically-basic theme could not be found.


Warning: github-pages can’t satisfy your Gemfile’s dependencies.
17/usr/local/bundle/gems/jekyll-3.9.3/lib/jekyll/theme.rb:84:in `rescue in gemspec’: The jekyll-theme-basically-basic theme could not be found. (Jekyll::Errors::MissingDependencyException)

My apologies for my thick-headedness, what exactly is the path of the gemfile I could perhaps try deleting?

Perhaps using a newer, more updated Jekyll Theme at this point might be a better alternative if this cannot be rectified.

the gemfile is just floating in the root of your file, you can try deleting it and see what happens, there was nothing in it other than the jekyll version. It is not required.

I don’t like themes, and have never used one. I prefer to have all the files in my repo as it is less obtuse.

It kind of looks like you cloned the theme repo? this is good and what I like to do. If you do this you don’t need the theme setting in the config cause you aren’t using a theme - the theme is your actual site already.

in your config the theme is on line 37 - theme: jekyll-theme-basically-basic you can probably remove this or put a # in front of it to comment it out.

I have deleted the Gemfile, I have also commented out line 37. The repo was cloned.

As for seeing if any updates take place wont it just be stuck in some sort of limbo because of the failed build? Should I initiate a manual build now?
Nevermind, It already auto-built, but success!?


I am also at my limit for replies as a new user for the next 22 hours so I’ll just have to edit this reply from now on haha

I’ll just let everything propagate out for 10-15 minutes to see if it actually has worked.

Yup, just used edge to get around the DNS cache thingie.
Thank you so much for your help :slight_smile:

it looks to be working now - though in my chrome browser where I originally looked at it it is still caching the dns redirect.

If you can’t pull it up try a different browser or incognito mode and it should work. I’m not sure how the browser is caching the redirect but sometimes these things happen and make it seem like it isn’t working when it really is.