Cannot Deploy Site Via GitHub

Complete newbie to this and just cant get my head around jekyll at all.
No idea what ive done wrong, not even wanting to have the file its struggling with i just dont get this one bit.

For context, just trying to see my page on my domain i know theres 0 content in it just now

We need a lot more context to help you here. What have you tried? Did you enable GitHub pages? Jekyll does not appear to be installed in this repo, so if you just want the web page to run as a GitHub page, it should work. Are there errors you are getting?

Happy to help if you can provide context.

Hi there, So I’ve installed jekyll on my computer, enabled github pages and linked everything all good. When trying to push a basic html file im getting the error

Conversion error: Jekyll::Converters::Scss encountered an error while converting ‘assets/css/style.scss’:

18 No such file or directory @ dir_chdir - /github/workspace/docs.

Not sure exactly what from jekyll i need to put in the repository for it to work, i dont necessarily need jekyll but it doesnt seem to be giving me any choice. Hope this helps more and would be happy to answer any questions

I don’t understand what caused your error.

Try rename Index.html to index.html and delete your CNAME. Keep things simple to get it working.

You can also try make a copy of my template which is plain HTML on GH Pages with almost no Jekyll used (change the homepage to index.md if you like)

Or a simple one page Jekyll site

You can try index.html in your root like I did here

Or use a full Jekyll site when you are ready

So i tried removing CNAME and renamed it to index.html and its still giving me back the same error. I’d honestly ideally avoid using jekyll right now as i dont understand it but its not seeming like thats an option given the error code I am getting.

It keeps looking for ‘assets/css/style.scss’: but im not at the stage of wanting to add css yet so that file doesnt exist for that reason

That’s weird. Jekyll on GH Pages is supposed to work fine as a single index page and you don’t have any reference to CSS or SCSS in your code.

Can you give a screenshot to show where you are seeing the error?

Also note you can edit and rename files directly GitHub without having to upload.

Also you can try click Use Template button on one I suggested, turn on GH Pages, check Environment tab for link. And then once you have a template working, on then put in your own HTML file

If you use Netlify instead and some HTML files, you can avoid Jekyll and GH Pages completely. While keeping GitHub

Here is where I am seeing it.

May look into netlify as jekyll is seeming too complicated. Thank you for your help so far!

Thanks. Hmm that is using a theme but then it can’t find the files the theme uses.

Make sure theme is none in your GH Pages settings.

Or make a file

_config.yml

Contents

theme: ''

Also check your GH Pages configuration is for root and not docs or something.

It looks like you are trying to run a Jekyll build on top of a standard GH Pages repo. You do not have to do that. All you need to do is enable GitHub Pages and your site will build automatically. After you get comfortable using Jekyll, you can then start building your site with GH actions or workflows. In other words, you are maybe going too far too soon :slight_smile:

Please take a quick look at a few videos I created to get you up and running with GH Pages and Jekyll:

2 Likes

This has solved it, i think when i got the error i was playing around with things trying to sort it and this was one of them, changed it back now ran it and it seems to work fine. Going to try readding CNAME to see if itll work now but its looking positive! Thanks for your help!

1 Like

That appears to have been the case, ive unintentionally involved jekyll. Will defo give these a watch through as im building the website thank you for your help!

1 Like

Just confirming now CNAME readded and all good, thanks for your help @MichaelCurrin and @BillRaymond

3 Likes