Posts are not being generated under /categories/guides folder and pulling up an error

I have a Jekyll site built that runs normally and generates almost everything well as expected. The only issue that I’ve been working on for a while is getting the posts to generate and show up. I already made sure the titles of the markdown files of the posts began in YYYY-MM-DD format and here is what one example of one of the front matters of the post that I have right now.

layout: post
title: New Features
author: Jocelyn Dzuong
date: '2020-04-20 16:07:20 +0530'
summary: New infrastructure update
categories: guides

text here

I forked the Devlopr theme here and edited the CSS and some of the layouts of the template pages. One thing I noticed though is that in the original theme repo, the permalink for the categories for the posts seem to have a permalink to blog/categories/[category name here]. But when I check in the blog directory, there is no categories folder at all, yet the website still runs. Here is also my _config.yml file if it helps:

baseurl: "/" # the subpath of your site, e.g. /blog

    - text: About
      url: /about
    - text: Writeups
      url: /blog
    - text: Achievements
      url : /contact

#      external_url:
#      external_url:

# Edit these details

author_logo: ufsitlogo.png
author: UFSIT
author_subtitle: UF Student Infosec Team
author_bio: text here
author_email: ""
author_location: Florida
author_website_url: ""

# social links
twitter_username: ufsit
github_username:  ufsit
facebook_username: ufsit
youtube_username: ufsit

#for comments using disqus
disqus_shortname: user

# syntax highlighter
markdown: kramdown
highlighter: rouge
permalink: pretty

# google analytics
google_analytics: UA-46783401-10

# algolia search
  application_id: D9WA1YKTRQ
  index_name: blog_posts # You can replace that with whatever name you want
  files_to_exclude: []
  nodes_to_index: 'article'
  search_only_api_key: 58ffdd7cd6c45ec1577a7fcd789b1b9a

# pagination of posts
paginate: 4
per_page: 4
paginate_path: "/blog/page/:num/"

# minify
# compress_html:
#   clippings: all
#   comments: ["<!-- ", " -->"]
#   endings: all
#   ignore:
#     envs: ['development']

# Build settings
  - jekyll-feed
  - jekyll-paginate
  - jekyll-gist
  - jekyll-seo-tag
  - jekyll-sitemap
  - jekyll-algolia
  - jekyll-menus

# Exclude from processing.
# The following items will not be processed, by default.
# Any item listed under the `exclude:` key here will be automatically added to
# the internal "default list".
# Excluded items can be processed by explicitly listing the directories or
# their entries' file path in the `include:` list.
  - .sass-cache/
  - .jekyll-cache/
  - gemfiles/
  - Gemfile
  - Gemfile.lock
  - node_modules/
  - vendor/bundle/
  - vendor/cache/
  - vendor/gems/
  - vendor/ruby/

destination: ./build
future: true

So when I go to run jekyll serve the site generates well but clicking on the posts to view them, it gives me a not found error with the link being /guides/2020/04/20/new-features which doesn’t show up in my files either, there isn’t even a guides directory at all. Any help?

maybe it’s a pasting error but you seem to be missing the --- at the start of your post. date is a metadata that’s obtained from the filename so it’s not needed on the frontmatter and it may the colluding with jekyll’s parsing. if you need the time i would recommend using another key name. i think plural categories should be an array and not a string. if you need a single category the key should be category and jekyll converts it to array categories internally.