Jekyll on Windows: Cannot locate directory after creating a new project

Hello folks,

I am very new to Jekyll and to using the terminal. I have installed “Bash on Ubuntu on Windows” and Jekyll and I have created a new project using this terminal. Unfortunately, I cannot seem to locate the project I just created. Actually, I do know where my project is located (in the /home/[username]/… directory), but that directory is NOT in my computer.

In other words, the path to the project does not start with C:/… like normal paths usually do. In fact, the path has a structure that is very similar to Linux/MacOS systems. I have tried to look for the project using File Explorer and the start menu but it is no where to be found.

I have looked for similar issues on the Jekyll FAQ and SOF to no avail. This issue is completely stopping me from progressing with Jekyll and because I am still a beginner, I have no idea how to go about this.

Any help is appreciated.

EDIT: problem solved! Apparently, the root directory for “Bash on Ubuntu on Windows” is C:\Users[Username]\AppData\Local\Lxss\rootfs (see this post for a complete explanation: .

Any folder/file within this directory is apparently separate from your computer and can’t be searched for in file explorer or the start menu. Once you go to C:\Users[Username]\AppData\Local\Lxss\rootfs you can easily find your project in whatever folder you placed it in.

I use windows, but don’t use Bash - just the standard command prompt or powershell.

Have you tried using one of those? and then specifying an exact place to do it on your C drive?

In Windows Explorer if you hold down Shift while Right-clicking a folder you should see an option to Open Powershell Here that I find handy. So you could make a folder on your C or D drive called Projects or something and then open powershell there and then run the jekyll command.

Hey @rdyar, I have only tried to use Bash because I was told it would be the best interface for Jekyll on the official website. My unfamiliarity with terminals is the cause of this, but after a lot of research I have finally solved the problem. I will edit the post shortly with the solution in case anyone else is also stuck on this.

Thanks for your help!