Where is Jekyll installed?

Hi all – I successfully installed Ruby and Jekyll as per the instructions on the website. Now I’m stumped. Where is Jekyll installed? I can’t find it.

I’m using Ubuntu 18.04.1 via the Windows Subsystem for Linux on Windows 10. Thanks for your help.

from what I understand jekyll is just a ruby gem. Where ever ruby is there will be a folder somewhere with all the gems, of which one will be Jekyll.

What are you trying to do?

gem info jekyll

*** LOCAL GEMS ***

jekyll (3.8.5, 3.7.4)
    Author: Tom Preston-Werner
    Homepage: https://github.com/jekyll/jekyll
    License: MIT
    Installed at (3.8.5): /Users/frank/gems
                 (3.7.4): /Users/frank/gems

    A simple, blog aware, static site generator.

Thanks. I’m trying to figure out where Jekyll is putting the site’s files when it builds it. This made me realize that I don’t even know where Jekyll is. I’m often confused by where things are in Linux when instructions don’t stipulate a directory to be in before taking the subsequent steps.

they should be in the same folder as your source files, inside the _site folder.

You can run jekyll from any folder I think as long as the Environment Variable has the path to ruby(?).

Huh, the command isn’t working for me. I’ve tried:

gem info jekyll

gem list

And I get /usr/bin/env: ‘ruby’: No such file or directory in both cases.

What’s happening? Do I need to set an environment variable somewhere?

Note: I ran autoclean, clean, and autoremove after I installed ruby and a bunch of updates to installed packages. I don’t know if that would be relevant here.

I tried opening usr/bin/env with vi but it doesn’t seem to be a text file, which makes sense given that it’s in the bin directory.


I have: C:\Ruby25-x64\bin as a path variable,
But it may be different depending on where you have ruby installed.

I run jekyll on windows and just use a regular command prompt or powershell. No need for the linux subsystem, I’ve never understood what that gets you.

I’m using Ubuntu on the WSL, so the Windows paths shouldn’t apply.

I rarely succeed at getting Ruby to work right on Windows (native Windows, not the WSL). Typically I get errors when trying to install gems like Jekyll where it tries to build native extensions. It will complain about the version of cygwin or mingw or something. This is with the standard Ruby Installer for Windows. I’ll try it again and see if I can get past all the errors.

that sounds like you don’t have the devkit version - there are 2 versions of Ruby for windows, one includes the devkit the other does not. If you don’t have it then it can’t build the native extensions.

Yes, I always install the DevKit version. Right now, I’ve got Ruby 2.6.1 64-bit installed, with the DevKit, on Windows 10. (This is in addition to the Ruby 2.5.3 installed in the WSL/Ubuntu that I’ve been using for most of this thread.) Here’s the error I get in Windows:


Any ideas?

I think that means your path is ok. Have you done what it says to see if there is more than one version of cygwin? Maybe uninstall and reinstall it?

I think you can do gem list to see what is installed, maybe it will show you something.