Incompatible with the current version, ruby 3.0

I’m running into this error ruby_dep-1.5.0 requires ruby version >= 2.2.5, ~> 2.2, which is incompatible
with the current version, ruby 3.0.0p0 when trying to bundle exec jekyll serve any thoughts?

1 Like

Easiest is to downgrade to Ruby 2.7 as that has been in use a lot time with Jekyll.

Someone posted recently in the forums to say Ruby 3 works fine with Jekyll - he just had to delete all his system gems (i.e. remove Ruby 2 cleanly and then setup Ruby 3).

so I installed my ruby via brew following these steps - Jekyll on macOS | Jekyll • Simple, blog-aware, static sites how would you downgrade to 2.7?

brew install ruby@2.7

My guide Install Ruby and Bundler · GitHub

1 Like

I wrote that Ruby 3 works well, but “delete all his system gems” it was not – just the ~/gems directory, and that rebuilt itself.

Oh good thanks for jumping in.

At the end of the Terminal window pointed properly at the subject folder …

I get this after running …

Bundle install

ruby_dep-1.5.0 requires ruby version ~> 2.2, >= 2.2.5,

;which is incompatible with the current version, ruby 3.0.1p64

Notice: Same warning w Ruby 3.01 as w Ruby 3.0.0

I’ve also tried purging the gem ruby_dep, but that doesn’t seem to work either, as follows:

gem uninstall ruby_dep-1.5.0


Gem ‘ruby_dep-1.5.0’ is not installed.

Yet there is still a warning call for “ruby_dep-1.5.0” …

That requires an ancient ruby version at the end of running of …

Bundle install

FYI: “ruby_dep-1.5.0” has a last “worked on” version date of October 09, 2016


1.) Disable #gem ‘listen’, ‘3.1.5’ from Gemfile;

2.) Crank the version of github-pages down from 214 to 213 via the Gemfile;

3.) Bundle update

Working …

Using github-pages 213

Bundle updated!

1 Like

that really works! Thank you!

1 Like