Wrong number of arguments (given 2, expected 1)

Using Mac OS 11.1 and had to install Jekyll

$ ruby -v
ruby 3.0.0p0 (2020-12-25 revision 95aff21468) [x86_64-darwin20]

$ which ruby
/usr/local/opt/ruby/bin/ruby

after installing Jekyll and bundler and updating gemfile I get the error jekyll 3.8.7 | Error: wrong number of arguments (given 2, expected 1)

$ jekyll s
Configuration file: /Users/Yuriy/Documents/Blog/_config.yml
Source: /Users/Yuriy/Documents/Blog
 Destination: /Users/Yuriy/Documents/Blog/_site
 Incremental build: disabled. Enable with --incremental
Generating...
 jekyll 3.8.7 | Error: wrong number of arguments (given 2, expected 1)

/usr/local/Cellar/ruby/3.0.0_1/lib/ruby/3.0.0/csv.rb:1656:in `read': **wrong number of arguments (given 2, expected 1) (** **ArgumentError** **)**

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:57:in `read_data_file'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:46:in `block in read_data_to'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:38:in `each'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:38:in `read_data_to'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:20:in `read'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/reader.rb:18:in `read'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/site.rb:164:in `read'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/site.rb:69:in `process'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/command.rb:28:in `process_site'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/build.rb:65:in `build'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/build.rb:36:in `process'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `block in start'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `each'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `start'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:75:in `block (2 levels) in init_with_program'

from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `block in execute'

from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `each'

from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `execute'

from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/program.rb:42:in `go'

from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary.rb:19:in `program'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/exe/jekyll:15:in `<top (required)>'

from /usr/local/bin/jekyll:23:in `load'

from /usr/local/bin/jekyll:23:in `<main>'

Yuriys-MacBook-Pro:Blog Yuriy$ bundle exec jekyll serve

bundler: failed to load command: jekyll (/usr/local/lib/ruby/gems/3.0.0/bin/jekyll)

/usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/html.rb:10:in `require': **cannot load such file -- rexml/parsers/baseparser (** **LoadError** **)**

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/html.rb:10:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown/html.rb:10:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown/html.rb:10:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown/paragraph.rb:14:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown/paragraph.rb:14:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown.rb:345:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown.rb:345:in `<class:Kramdown>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown.rb:60:in `<module:Parser>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown.rb:19:in `<module:Kramdown>'

from /usr/local/lib/ruby/gems/3.0.0/gems/kramdown-1.17.0/lib/kramdown/parser/kramdown.rb:17:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/converters/smartypants.rb:3:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/converters/smartypants.rb:3:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll.rb:13:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll.rb:13:in `block in require_all'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll.rb:12:in `each'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll.rb:12:in `require_all'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll.rb:194:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/exe/jekyll:8:in `require'

from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/exe/jekyll:8:in `<top (required)>'

from /usr/local/lib/ruby/gems/3.0.0/bin/jekyll:23:in `load'

from /usr/local/lib/ruby/gems/3.0.0/bin/jekyll:23:in `<top (required)>'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:63:in `load'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:63:in `kernel_load'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli/exec.rb:28:in `run'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli.rb:494:in `exec'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/command.rb:27:in `run'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in `invoke_command'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor.rb:392:in `dispatch'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli.rb:30:in `dispatch'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/vendor/thor/lib/thor/base.rb:485:in `start'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/cli.rb:24:in `start'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/exe/bundle:49:in `block in <top (required)>'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/lib/bundler/friendly_errors.rb:130:in `with_friendly_errors'

from /Users/Yuriy/.gem/ruby/3.0.0/gems/bundler-2.2.4/exe/bundle:37:in `<top (required)>'

from /usr/local/opt/ruby/bin/bundle:23:in `load'

from /usr/local/opt/ruby/bin/bundle:23:in `<main>'

Two other topics on this help didn’t help. Unfortunately, I have no clue what is going on.

the first one sort of looks like an error in a data file - do you have a data file? csv?

is there a link to your repo you can share?

the second one sort of looks like you have ruby installed twice? once in /usr and another in /Users? i would look and see if you have ruby installed twice, if so uninstall it and then reinstall? I’m not a mac user so maybe this is normal somehow, but it seems suspicious.

my repo https://github.com/Yuriysteam/yuriysteam.github.io which is a GitHub page web

2nd this is very strange. I will try to reinstall it. Thx

after Ruby reinstall

$ ruby -v
ruby 3.0.0p0 (2020-12-25 revision 95aff21468) [x86_64-darwin20]

$ which ruby
/usr/local/opt/ruby/bin/ruby

$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 3.2.3
  - RUBY VERSION: 3.0.0 (2020-12-25 patchlevel 0) [x86_64-darwin20]
  - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/3.0.0
  - USER INSTALLATION DIRECTORY: /Users/Yuriy/.local/share/gem/ruby/3.0.0
  - RUBY EXECUTABLE: /usr/local/opt/ruby/bin/ruby
  - GIT EXECUTABLE: /usr/bin/git
  - EXECUTABLE DIRECTORY: /usr/local/lib/ruby/gems/3.0.0/bin
  - SPEC CACHE DIRECTORY: /Users/Yuriy/.local/share/gem/specs
  - SYSTEM CONFIGURATION DIRECTORY: /usr/local/Cellar/ruby/3.0.0_1/etc
  - RUBYGEMS PLATFORMS:
 - ruby
 - x86_64-darwin-20
  - GEM PATHS:
 - /usr/local/lib/ruby/gems/3.0.0
 - /Users/Yuriy/.local/share/gem/ruby/3.0.0
 - /usr/local/Cellar/ruby/3.0.0_1/lib/ruby/gems/3.0.0
  - GEM CONFIGURATION:
 - :update_sources => true
 - :verbose => true
 - :backtrace => false
 - :bulk_threshold => 1000
  - REMOTE SOURCES:
 - https://rubygems.org/
  - SHELL PATH:
 - /usr/local/lib/ruby/gems/3.0.0/bin
 - /usr/local/opt/ruby/bin
 - /usr/local/bin
 - /usr/bin
 - /bin
 - /usr/sbin
 - /sbin
 - /Library/Apple/usr/bin

bash profile.file
export PATH="/usr/local/opt/ruby/bin:$PATH"
export PATH="/usr/local/lib/ruby/gems/3.0.0/bin:$PATH"

after a new reinstallation and cleaning

$ jekyll s
Configuration file: /Users/Yuriy/Documents/Blog/_config.yml
            Source: /Users/Yuriy/Documents/Blog
       Destination: /Users/Yuriy/Documents/Blog/_site
 Incremental build: disabled. Enable with --incremental
      Generating... 
jekyll 3.8.7 | Error:  wrong number of arguments (given 2, expected 1)
/usr/local/Cellar/ruby/3.0.0_1/lib/ruby/3.0.0/csv.rb:1656:in `read': wrong number of arguments (given 2, expected 1) (ArgumentError)
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:57:in `read_data_file'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:46:in `block in read_data_to'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:38:in `each'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:38:in `read_data_to'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/readers/data_reader.rb:20:in `read'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/reader.rb:18:in `read'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/site.rb:164:in `read'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/site.rb:69:in `process'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/command.rb:28:in `process_site'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/build.rb:65:in `build'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/build.rb:36:in `process'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `block in start'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `each'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:93:in `start'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/lib/jekyll/commands/serve.rb:75:in `block (2 levels) in init_with_program'
	from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `block in execute'
	from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `each'
	from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/command.rb:220:in `execute'
	from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary/program.rb:42:in `go'
	from /usr/local/lib/ruby/gems/3.0.0/gems/mercenary-0.3.6/lib/mercenary.rb:19:in `program'
	from /usr/local/lib/ruby/gems/3.0.0/gems/jekyll-3.8.7/exe/jekyll:15:in `<top (required)>'
	from /usr/local/lib/ruby/gems/3.0.0/bin/jekyll:23:in `load'
	from /usr/local/lib/ruby/gems/3.0.0/bin/jekyll:23:in `<main>'

At the moment, Jekyll isn’t very compatible with Ruby 3, particularly Jekyll 3.9 (used by Github Pages). I’m using Homebrew (looks like you maybe too), so I’ve had to switch to the ruby@27 formula for now.

Jekyll 3 and 4 will probably get patched in the next few months to run smoothly under Ruby 3, but until then I would avoid it.

1 Like

Thank you. Tried it. Still gives an error. :frowning:

$ jekyll s

**Traceback** (most recent call last):

10: from /usr/local/lib/ruby/gems/2.7.0/bin/jekyll:23:in `<main>'

9: from /usr/local/lib/ruby/gems/2.7.0/bin/jekyll:23:in `load'

8: from /usr/local/lib/ruby/gems/2.7.0/gems/jekyll-4.2.0/exe/jekyll:11:in `<top (required)>'

7: from /usr/local/lib/ruby/gems/2.7.0/gems/jekyll-4.2.0/lib/jekyll/plugin_manager.rb:52:in `require_from_bundler'

6: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler.rb:149:in `setup'

5: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/runtime.rb:26:in `setup'

4: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/runtime.rb:26:in `map'

3: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/spec_set.rb:149:in `each'

2: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/spec_set.rb:149:in `each'

1: from /usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/runtime.rb:31:in `block in setup'

/usr/local/lib/ruby/gems/2.7.0/gems/bundler-2.2.4/lib/bundler/runtime.rb:302:in `check_for_activated_spec!': **You have already activated i18n 1.8.6, but your Gemfile requires i18n 0.9.5. Prepending `bundle exec` to your command may solve this. (** **Gem::LoadError** **)**

bundle exec jekyll s – worked!

But how to fix the errors to just run jekyll s?

$ bundle check
The Gemfile's dependencies are satisfied

maybe this? your version of that is too new? when you do bundle execute it is probably fixing this. When you do jekyll s it is not? not a bundle user so not sure.

I am also not sure how it should be fixed. My gemfile.lock looks like this and I can update it manually:

GEM
  remote: https://rubygems.org/
  specs:
    activesupport (6.0.3.4)
      concurrent-ruby (~> 1.0, >= 1.0.2)
      i18n (>= 0.7, < 2)
      minitest (~> 5.1)
      tzinfo (~> 1.1)
      zeitwerk (~> 2.2, >= 2.2.2)
    addressable (2.7.0)
      public_suffix (>= 2.0.2, < 5.0)
    coffee-script (2.4.1)
      coffee-script-source
      execjs
    coffee-script-source (1.11.1)
    colorator (1.1.0)
    commonmarker (0.17.13)
      ruby-enum (~> 0.5)
    concurrent-ruby (1.1.7)
    dnsruby (1.61.5)
      simpleidn (~> 0.1)
    em-websocket (0.5.2)
      eventmachine (>= 0.12.9)
      http_parser.rb (~> 0.6.0)
    ethon (0.12.0)
      ffi (>= 1.3.0)
    eventmachine (1.2.7)
    execjs (2.7.0)
    faraday (1.3.0)
      faraday-net_http (~> 1.0)
      multipart-post (>= 1.2, < 3)
      ruby2_keywords
    faraday-net_http (1.0.0)
    ffi (1.14.2)
    forwardable-extended (2.6.0)
    gemoji (3.0.1)
    github-pages (209)
      github-pages-health-check (= 1.16.1)
      jekyll (= 3.9.0)
      jekyll-avatar (= 0.7.0)
      jekyll-coffeescript (= 1.1.1)
      jekyll-commonmark-ghpages (= 0.1.6)
      jekyll-default-layout (= 0.1.4)
      jekyll-feed (= 0.15.1)
      jekyll-gist (= 1.5.0)
      jekyll-github-metadata (= 2.13.0)
      jekyll-mentions (= 1.6.0)
      jekyll-optional-front-matter (= 0.3.2)
      jekyll-paginate (= 1.1.0)
      jekyll-readme-index (= 0.3.0)
      jekyll-redirect-from (= 0.16.0)
      jekyll-relative-links (= 0.6.1)
      jekyll-remote-theme (= 0.4.2)
      jekyll-sass-converter (= 1.5.2)
      jekyll-seo-tag (= 2.6.1)
      jekyll-sitemap (= 1.4.0)
      jekyll-swiss (= 1.0.0)
      jekyll-theme-architect (= 0.1.1)
      jekyll-theme-cayman (= 0.1.1)
      jekyll-theme-dinky (= 0.1.1)
      jekyll-theme-hacker (= 0.1.2)
      jekyll-theme-leap-day (= 0.1.1)
      jekyll-theme-merlot (= 0.1.1)
      jekyll-theme-midnight (= 0.1.1)
      jekyll-theme-minimal (= 0.1.1)
      jekyll-theme-modernist (= 0.1.1)
      jekyll-theme-primer (= 0.5.4)
      jekyll-theme-slate (= 0.1.1)
      jekyll-theme-tactile (= 0.1.1)
      jekyll-theme-time-machine (= 0.1.1)
      jekyll-titles-from-headings (= 0.5.3)
      jemoji (= 0.12.0)
      kramdown (= 2.3.0)
      kramdown-parser-gfm (= 1.1.0)
      liquid (= 4.0.3)
      mercenary (~> 0.3)
      minima (= 2.5.1)
      nokogiri (>= 1.10.4, < 2.0)
      rouge (= 3.23.0)
      terminal-table (~> 1.4)
    github-pages-health-check (1.16.1)
      addressable (~> 2.3)
      dnsruby (~> 1.60)
      octokit (~> 4.0)
      public_suffix (~> 3.0)
      typhoeus (~> 1.3)
    html-pipeline (2.14.0)
      activesupport (>= 2)
      nokogiri (>= 1.4)
    http_parser.rb (0.6.0)
    i18n (0.9.5)
      concurrent-ruby (~> 1.0)
    jekyll (3.9.0)
      addressable (~> 2.4)
      colorator (~> 1.0)
      em-websocket (~> 0.5)
      i18n (~> 0.7)
      jekyll-sass-converter (~> 1.0)
      jekyll-watch (~> 2.0)
      kramdown (>= 1.17, < 3)
      liquid (~> 4.0)
      mercenary (~> 0.3.3)
      pathutil (~> 0.9)
      rouge (>= 1.7, < 4)
      safe_yaml (~> 1.0)
    jekyll-avatar (0.7.0)
      jekyll (>= 3.0, < 5.0)
    jekyll-coffeescript (1.1.1)
      coffee-script (~> 2.2)
      coffee-script-source (~> 1.11.1)
    jekyll-commonmark (1.3.1)
      commonmarker (~> 0.14)
      jekyll (>= 3.7, < 5.0)
    jekyll-commonmark-ghpages (0.1.6)
      commonmarker (~> 0.17.6)
      jekyll-commonmark (~> 1.2)
      rouge (>= 2.0, < 4.0)
    jekyll-default-layout (0.1.4)
      jekyll (~> 3.0)
    jekyll-feed (0.15.1)
      jekyll (>= 3.7, < 5.0)
    jekyll-gist (1.5.0)
      octokit (~> 4.2)
    jekyll-github-metadata (2.13.0)
      jekyll (>= 3.4, < 5.0)
      octokit (~> 4.0, != 4.4.0)
    jekyll-mentions (1.6.0)
      html-pipeline (~> 2.3)
      jekyll (>= 3.7, < 5.0)
    jekyll-optional-front-matter (0.3.2)
      jekyll (>= 3.0, < 5.0)
    jekyll-paginate (1.1.0)
    jekyll-readme-index (0.3.0)
      jekyll (>= 3.0, < 5.0)
    jekyll-redirect-from (0.16.0)
      jekyll (>= 3.3, < 5.0)
    jekyll-relative-links (0.6.1)
      jekyll (>= 3.3, < 5.0)
    jekyll-remote-theme (0.4.2)
      addressable (~> 2.0)
      jekyll (>= 3.5, < 5.0)
      jekyll-sass-converter (>= 1.0, <= 3.0.0, != 2.0.0)
      rubyzip (>= 1.3.0, < 3.0)
    jekyll-sass-converter (1.5.2)
      sass (~> 3.4)
    jekyll-seo-tag (2.6.1)
      jekyll (>= 3.3, < 5.0)
    jekyll-sitemap (1.4.0)
      jekyll (>= 3.7, < 5.0)
    jekyll-swiss (1.0.0)
    jekyll-theme-architect (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-cayman (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-dinky (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-hacker (0.1.2)
      jekyll (> 3.5, < 5.0)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-leap-day (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-merlot (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-midnight (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-minimal (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-modernist (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-primer (0.5.4)
      jekyll (> 3.5, < 5.0)
      jekyll-github-metadata (~> 2.9)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-slate (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-tactile (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-theme-time-machine (0.1.1)
      jekyll (~> 3.5)
      jekyll-seo-tag (~> 2.0)
    jekyll-titles-from-headings (0.5.3)
      jekyll (>= 3.3, < 5.0)
    jekyll-watch (2.2.1)
      listen (~> 3.0)
    jemoji (0.12.0)
      gemoji (~> 3.0)
      html-pipeline (~> 2.2)
      jekyll (>= 3.0, < 5.0)
    kramdown (2.3.0)
      rexml
    kramdown-parser-gfm (1.1.0)
      kramdown (~> 2.0)
    liquid (4.0.3)
    listen (3.4.0)
      rb-fsevent (~> 0.10, >= 0.10.3)
      rb-inotify (~> 0.9, >= 0.9.10)
    mercenary (0.3.6)
    mini_portile2 (2.4.0)
    minima (2.5.1)
      jekyll (>= 3.5, < 5.0)
      jekyll-feed (~> 0.9)
      jekyll-seo-tag (~> 2.1)
    minitest (5.14.2)
    multipart-post (2.1.1)
    nokogiri (1.10.10)
      mini_portile2 (~> 2.4.0)
    octokit (4.20.0)
      faraday (>= 0.9)
      sawyer (~> 0.8.0, >= 0.5.3)
    pathutil (0.16.2)
      forwardable-extended (~> 2.6)
    public_suffix (3.1.1)
    rb-fsevent (0.10.4)
    rb-inotify (0.10.1)
      ffi (~> 1.0)
    rexml (3.2.4)
    rouge (3.23.0)
    ruby-enum (0.8.0)
      i18n
    ruby2_keywords (0.0.2)
    rubyzip (2.3.0)
    safe_yaml (1.0.5)
    sass (3.7.4)
      sass-listen (~> 4.0.0)
    sass-listen (4.0.0)
      rb-fsevent (~> 0.9, >= 0.9.4)
      rb-inotify (~> 0.9, >= 0.9.7)
    sawyer (0.8.2)
      addressable (>= 2.3.5)
      faraday (> 0.8, < 2.0)
    simpleidn (0.1.1)
      unf (~> 0.1.4)
    terminal-table (1.8.0)
      unicode-display_width (~> 1.1, >= 1.1.1)
    thread_safe (0.3.6)
    typhoeus (1.4.0)
      ethon (>= 0.9.0)
    tzinfo (1.2.9)
      thread_safe (~> 0.1)
    unf (0.1.4)
      unf_ext
    unf_ext (0.0.7.7)
    unicode-display_width (1.7.0)
    zeitwerk (2.4.2)

PLATFORMS
  ruby
  x86_64-darwin-20

DEPENDENCIES
  github-pages

BUNDLED WITH
   2.2.4

Deleting and creating a new one with trying bundle will make the same file again.

Why do you want to run jekyll without bundler? if you use bundler and it works that is how you are supposed to do it I believe. I don’t think it would be normal to run jekyll both with and without bundler, that would defeat the purpose of bundler.

you could try deleting the i18n that you have then try installing just it as version 0.9.5? then do jekyll s and see if it works.

I think bundler is doing this and that is why it worked.

1 Like

As @rdyar said, the conventional way to run Jekyll is with bundle exec, which allows you to develop different project with different Jekyll requirements. If you’re only developing Github Pages projects, then you could remove all Jekyll gems except 3.9.0, and then raw jekyll will work (until Github Pages changes its requirements). E.g.:

gem uninstall jekyll:4.2.0

Personally, I define a short alias (j) to make it easier to use bundle exec than not:

alias j='bundle exec jekyll'
1 Like

Prefixing your commands bundle exec will help you to solve issues when having multiple versions of the same gems, since nothing stops you to do that.

However if you still want to run just jekyll s you can set a pessimistic version constraint in your Gemfile, like:

gem 'jekyll', '~> 3.9'

Update your dependencies

bundle update

And then clean all the gems not declared in your Gemfile

bundle clean

:warning: Be aware that after running bundle clean you might need to run bundle install again on other Ruby projects, to reinstall the required gems. :warning:

2 Likes

The comments above are correct. Use Ruby 2.7 and use Jekyll through bundle exec. And had Jekyll 3.9

Note that from 3.9 you need explicitly add a parser like this otherwise you’ll get a build error.

For anyone using Jekyll 4, you don’t have to worry about the parse as it is already covered as a dependency

after a clean reinstall and setting 3. gem “jekyll”, “~> 3.9” it all worked!

Thank you overmuch for your help.

1 Like