Css not found error

Dunno whats happening here but…

On ‘Jekyll Serve --watch’ I have just noticed I’m getting the following error -ERROR/_sass/Plugins/custom/footer/_footer.scss’ not found.` along with same error for several other files in my bourbon/base/neat folders… (so I have obviously made a change back sometime ago but never realised)

However… my structure - all seems tickety link to my github and likewise the various @import structures within app.sass and custom.scss look ok.

The odd thing though is that the page is rendering as it should on localhost which as far as I can make out it shouldn’t, if serve says files are not found?

so - If everything is rendering correctly, is this message something I should bother about or just live with it?

Here’s the full error so you see what I mean… It’s not reporting all the bourbon/base fies etc missing so its obviously going to the correct folders on serve…

[2017-07-06 13:47:47] ERROR /_sass/Plugins/base/_buttons.scss' not found. [2017-07-06 13:47:48] ERROR/_sass/Plugins/base/_variables.scss’ not found.
[2017-07-06 13:47:48] ERROR /_sass/Plugins/bourbon/bourbon/settings/_settings.scss' not found. [2017-07-06 13:47:48] ERROR/_sass/Plugins/base/_lists.scss’ not found.
[2017-07-06 13:47:48] ERROR /_sass/Plugins/base/_forms.scss' not found. [2017-07-06 13:47:48] ERROR/_sass/Plugins/base/_layout.scss’ not found.
[2017-07-06 13:47:48] ERROR /_sass/Plugins/base/_tables.scss' not found. [2017-07-06 13:47:48] ERROR/_sass/Plugins/base/_typography.scss’ not found.
[2017-07-06 13:47:48] ERROR /_sass/Plugins/base/_media.scss' not found. [2017-07-06 13:47:48] ERROR/_sass/Plugins/custom/footer/_footer.scss’ not found.
[2017-07-06 13:47:48] ERROR `/_sass/Plugins/bourbon/bourbon/library/_modular-scale.scss’ not found.

Took a quick look at your repo and everything looks good to me. Also cloned your repo and tried to build it and didn’t get any of those Sass partial not found errors you included above.

I don’t think you’re doing anything wrong. Maybe a gem updated recently and is reporting false errors?

Do you see the same errors when you run jekyll build? I see you have a Gemfile… what happens if you use bundle exec jekyll serve --watch instead?

no idea bud…

Done build exec that didn’t give any errors, read up all day on google etc and found peeps had problems similar with site baseurl but I tried all that and no changes…

I’ve given up and started again as it was a fresh install… but with everthing apparantly the same and … well this time its working… odd.

Your probably on the right track though with the gems I imagine because of course now ive installed the bundle again and were all clear.

And as I’m a noob then getting to grips and faster with fresh installs is always good…

Tnx for taking the time out to peek… least I know I was bangin my head for no reason…

Trials and tribulations… Onward 'n upwards :smiley:

bundle exec is always a good idea. My guess is the wrong Sass gem was being used that was causing false errors.

1 Like

Aha… got the little bugger… So… I thought “I’m not happy with this, theres an error somewhere…” so… started all over again cos I love to tinker :smiley:

Ive found the culprit… Layout: default.

What Ive done is create a new Jekyll with my own folders layout etc, then in this latest git you can see have added a custom footer in plugins/custom.

Adding this to the now blank home.html works but doesn’t show the css rendered… so I added back into the yaml layout:default and wazaaaaa! Theres the error again.

and that’s with or without bundle exec
so now I have to work out why… as of course, you guessed it… when I have layout : default there then the css renders… but yet that also causes the error saying it’s not there!


so if you have nothing else to do today and feel like a nosey at all… Here’s another repo of where I’m at so far… :slight_smile:

Another repo… - commit no4

its something in “Head.html”

Because if I remove all the yaml from home.html so it looks like a regular html page…

home.html without Yaml - commit no 5

Then the css renders correctly but the error appears…

doin my head in this… heres a quick youtube snapshot Ive just uploaded so you can see what I mean.

Jekyll problem.

Couple of things to investigate:

1. All of your _layouts except page.html are missing the YAML --- blocks. These are needed by Jekyll so I would add them in, even if blank to rule out any weirdness.


2. Looks like you’re using the Sass CLI to generate your .css instead of Jekyll. Is this correct? If so then I would rename _sass to something else in case Jekyll is trying to process your Sass for you and getting confused. Especially since you’re missing --- Front Matter blocks and all that.

What I would suggest is keep all your partials in _sass and move _sass/app.sass to css/app.sass. And add the Front Matter blocks before the @import


You can then remove style.css and style.map, rename app.sass to style.sass and just let Jekyll build your CSS from Sass.

If done correctly you’ll end up with _site/css/style.css. It’ll probably be uncompressed, but you can change that by adding the relevant flags to Jekyll’s _config.yml


I can’t ty enough for that MM… Works like a charm. \o/

I was wondering about that too… I kept on trying to add --- to my original app.sass and kept getting errors when I saved it… Shows ya… wrong folder huh? :wink:

Commited to git and ready to crack on and let Jeckyll take care of the sass…

I can start playing now the foundations are right…

Tnx so much.