After I deleted template files in _posts, build fails for `gh-pages` branch

I have been getting a gh-pages branch page build error message ever since I deleted the original post files from a Jekyll template I forked (Milennial).

I am new to GitHub and Jekyll and I’ve been able to problem solve all the little things I’ve run into so far but still as a noob it may be something easy and obvious I am missing. I was able to change the css and made a couple of posts, all has been going well, until I deleted the original posts included in the template.

I haven’t been able to find the answer to this on any forums yet, and I apologize if it’s been asked already. I appreciate any help or if you can point me in the right direction.

Thank you!

Here’s a more detailed description:

I ran into a problem when I deleted the original template markdown files in the _posts folder. Ever since I have been unable to make any updates to any site files, incl css.

When I try to make edits, I receive this email with the subject: Page build failure.

And the following info:

"The page build failed for the gh-pages branch with the following error:

Page build failed. For more information, see”

Also… even though the files I deleted are not in the _posts folder, they still appear on my blog:

you a have post called new post but posts have to start with the date and probably should have an extension at the end like .md or .html - like the other two posts you have. Try changing that to and see if it works.

Thanks for your response. Actually I should clarify that the “new post” in there is something I quickly and randomly did yesterday while troubleshooting. I should have deleted that before posting this I guess - and I will delete it now.

The other two posts are the two posts I made a couple weeks back and I used the correct format. It wasn’t until about a week ago, after I deleted the how-to posts included in the template that I ran into this page build error.

Another weird thing is that even though I deleted the how-to posts included in the template, they still show up on the blog homepage. But they are not in the _pages folder since I deleted them. I’m guessing this has to do with forking?

Any thoughts?

Thanks for your time - I’m really looking forward to learning more and getting my site up. I appreciate any help here.

I’m not sure what the problem is.

I think the reason why the site shows old content is because you are getting a build error it is falling back to the last successful build.

That is not a very helpful error.

I don’t use GH pages very much so I don’t have much experience with it.

1 Like

Have you tried installing the GitHub Pages gem and building your site locally? It’ll give you more descriptive error messaging to help you pinpoint what the issue is.

I’m going to build the site locally thanks to your advice. Also Github support got back to me and they found that a line of code in the about file links to one of the original template posts, so that was breaking the site.

Initially my plan was to build it locally and I installed the gem. But then I wandered into the github fork territory to see if it might suit my needs and sort of wanting to know more about github. When I ran into the error message I decided to see it through in case I might learn something new. idk I think I’ve been a little too obsessed with this one quote: “No quitting half-way through because it’s not working. You get nothing from an unfinished project. You learn nothing.” Stephen J. Cannell

Thanks for the link and help.

1 Like