[SOLVED] Github : Page build failed: Symlink does not exist


I have been using jekyll for a blog on github for some time with no issues.
I tried to add a post to my jekyll blog on github. This is first post i have added since mid February.
I have only created a post changed no other files and the blog will not build now on github.
Something appears to have changed upstream
I am using 3.6.2 and theme minima. When i run locally using bundle exec jekyll serve, everything builds correctly, i.e i cannot recreate error locally.

The information from github by mail is as follows:

The page build failed for the master branch with the following error:
A file was included in /_layouts/default.html that is a symlink or does not exist in your _includes directory

There are 3 links in my /_layouts/default.html to header footer and head.html. , Header and footer exist
in my _includes. so i created a head.html but still got the page build error.

How do I proceed from here?
My jekyll blog on github is here


The reason is the recent versions of Minima no longer has includes/icon-github.html
Please refer README of
the latest version of Minima and update the following line accordingly…

thanks for reply
I cut all reference to git-hub icon but it did not work.
I see i am using minima 2.1.1

@typematrix When you push to GitHub Pages, the environment changes irrespective of your Gemfile. GHP always uses a single set of gems and their current versions are listed here.

To reproduce the errors locally, bundle your site with the latest version of the github-pages gem and try building again…

- gem "jekyll", "~> 3.4.2"
- gem "minima", "~> 2.0"
- #gem "github-pages", group: :jekyll_plugins
+ # gem "jekyll",  "~> 3.4.2"
+ # gem "minima", "~> 2.0"
+ gem "github-pages", group: :jekyll_plugins

then run

bundle update
bundle exec jekyll build


Thanks for help

I updated to minima 2.4.0 as per instructions and was able to generate the error, with proper error messages locally. The issue was with reference to the github icon as you said , I even had to remove a commented out reference to it from footer.html for it to build!?! Everything working now, solved, thanks.