SCSS: File to import not found or unreadable


I have built my user github page locally, and everything works fine.
However, when pushing to github, I get this error:

Your site is having problems building: Your SCSS file assets/stylesheets/site.SCSS has an error on line 2: File to import not found or unreadable: custom. Load paths: _sass /hoosegow/.bundle/ruby/2.3.0/gems/jekyll-theme-primer-0.1.7/_sass. For more information, see

The ‘custom’ file is in the _assets directory.
The full repository can be found here:

Any info on how to fix this?


Update your config.yml file. It may be that you have

    sass_dir: _sass /hoosegow/.bundle/ruby/2.3.0/gems/jekyll-theme-primer-0.1.7/_sass

instead of

sass_dir: _sass

I added a config file with the sass_dir as you said, but the same error is showing.

@RobbeSneyders, can you try renaming all .SCSS to .scss ?
If it was your sass settings, then _bootstrap.scss would’ve thrown an error too.


1 Like

Thanks, that worked.

I already changed them locally, but they weren’t marked as changes by git. I had to remove the .SCSS files first, commit, add the .scss files instead, and commit again.

The page now loads, but the includes in my home layout are not working. I’m trying to figure out why.

1 Like

I had .YAML as extension for my data files, which I had to changed to .yml to make it work.
Thanks for the help!

1 Like