Need help importing Joomla to Jekyll it doesn't recognize the mysql2 gem

Never done anything like this but I’m trying to take a data dump of SQL and run it through the jekyll-importer (can be found here and the source code here:

The error that is given to me after I run the code they told me to run on bash is this: " Whoops! Looks like you need to install ‘mysql2’ before you can use this importer.

If you’re using bundler: 1. Add ‘gem “mysql2”’ to your Gemfile 2. Run ‘bundle install’

If you’re not using bundler: 1. Run ‘gem install mysql2’. "

When I run my gem list it shows these related gems though:

jekyll (3.5.2)
jekyll-import (0.12.0)
jekyll-sass-converter (1.5.0)
jekyll-watch (1.5.0)
mysql2 (0.4.9 x64-mingw32, 0.3.16)

So i’m not sure why It can’t be read though I have mysql2. I have tried to bundle install like they suggest and I have also tried to gem install mysql2 like they suggest and both fail in downloading the correct gem. I’m not sure where to go from here.

Any suggestions or feedback will be appreciated

Did you do bundle uodate ?

So here is my bundle env:


Bundler   1.15.3
Rubygems  2.6.11
Ruby      2.4.1p111 (2017-03-22 revision 58053) [x64-mingw32]
Git       1.9.4.msysgit.2
Platform  x64-mingw32
OpenSSL   OpenSSL 1.0.2l  25 May 2017



source ''

gem "rubygems"
gem "sequel"
gem "mysql2"
gem "fileutils"
gem "safe_yaml"


<No C:/devl/workspaces/jekyllImport/Gemfile.lock found>

and bundle gets me this:

Fetching gem metadata from
Fetching version metadata from
Could not find gem ‘rubygems x64-mingw32’ in any of the gem sources listed in
your Gemfile.

But if i remove the rubygem and fileutils gems then the bundle is successfully updated:

Fetching gem metadata from
Fetching version metadata from
Resolving dependencies…
Using bundler 1.15.3
Using mysql2 0.4.9 (x64-mingw32)
Using safe_yaml 1.0.4
Using sequel 4.49.0
Bundle updated!