Jekyll Pages destroyed

Well, partially. The blog looks awfull and none of the links work. I must have damaged it somehow. As I am still a newbie I am desperately looking for help. Yours would be very much appreciated.

This sort of problem is often due to a bad url and/or baseurl fields in _config.yml. Could you give more details? I.e. your url/basurl values and examples of a broken link URLs vs correct URLs.

As @chuckhoupt points out, your _config.yml file is important. If you are running Jekyll with the livereload parameter, you will have to stop and start it again.

If you are creating links that are dynamically generated using Liquid, then make sure you are at least using the relative_url option.

Wrong way
<a class="footer-item" href="{{- item.url -}}">Click here</a>

Right way
<a class="footer-item" href="{{- item.url | relative_url -}}">Click here</a>

If the options we provide do not work, can you please provide a link to your GitHub repo?

1 Like

Jekyll Talk <>

Re: [Jekyll Talk] [Help] Jekyll Pages destroyed

Sa., 24. Apr. • 11:41

(Attachment _config.yml is missing)

It looks like you tried to attach a file which is not possible unless it is a photo. Which is a not a good idea for code.

Link to your repo on GitHub. If you have a file to share you can also upload as a gist or with a site like pastebin and then paste a link here.

For programming in general, the error log is your friend. In this case you might have a site that builds okay so Jekyll log won’t help

So I’d save go to settings in your browser and find the Dev Console and see the console tab. You’re going to probably see a CSS a file that could not be found and that will give you a clue on what is broken and what to fix.

A link to your webpage or a screenshot of the console log here will help us.

I am pretty sure that the problem is first if all caused by then _config.yaml. Unfortunately I cannot send it as attachment. I cannot send the two lines which are probably somehow wrong because the are identified as links of which I can send only two. I try anyhow.

baseurl: “/”
url: “

Your suggestions unfortunately require know how I don’t have. Using the browser to identify the source of the error is something I never did. I’m using FireFox.


We have been asking for your GutHub repo so we can look at the code to help you. I was able to reverse engineerit from your last post though.

I’m looking at your _config.yml file from following location:

From what I can tell looking at your website and the config file is your base url and url are incorrect. Try making the following change:

baseurl: "/"
url: ""

Setting the baseurl to / may cause problems with double-slashes in URLs (i.e. For sites at the root of a domain, an empty baseurl is best:

baseurl: ""
url: ""
1 Like

Oh that explains the extra slashes I sometimes find on my site. Thanks!

1 Like

This is correct

Use empty string

Or another example.

And giving username and repo name would be sufficient for us to find the repo.

A thousand thanks. It’s again all working fine - and it took just two minutes!. I cannot tell how happy I am.

Maybe I come back to the support with my stupid excerpt problem. But that’s maybe later.

Best regards


Thanks for your help. The problem is solved.

Best regards