GH pages 'baseurl' breaking Serve

I am completely new to Jekyll and am loving it! I ran into a problem that I wasn’t seeing previously (I changed to a different template) and now I am unable to use the localhost server after adding the baseurl to the _config.yml file for github pages.

If I have baseurl: oku-val commented out, the bundle exec jekyll serve command works fine, the site loads…all is well…

However, when I put the baseurl back in, serve breaks. When I run bundle exec jekyll serve , the output syntax of the server is wrong:

done in 0.153 seconds.
Auto-regeneration: enabled for ‘/home/tops/oku_val’
Server address:
Server running… press ctrl-c to stop.

I’m sure I’m just missing a tag but so far no luck…

Jekyll -v shows:

tops@tops-VirtualBox:~/oku_val$ jekyll -v
Warning: the running version of Bundler (2.1.2) is older than the version that created the lockfile (2.1.4). We suggest you to upgrade to the version that created the lockfile by running `gem install bundler:2.1.4`.
jekyll 4.2.2

I ran the command and no change.

Thanks for your help!

The baseurl should always start with a slash, because it must be an absolute path. I.e. /oku_val

A good article on url and basurl is:

Thank you. I was sure I tried that…but it makes sense looking over the documentation again…

I will try again tonight and report back!