I feel painful when I try to make jekyll usable

I am on Archlinux and I want to publish some words using jekyll and Github.
I success in 2014, gem install jekyll works well at that time. I am not a ruby coder, and I forget update gems since then. Recently I wanna repick jekyll, but find it is soooo hard to make jekyll usable.
I tried gem update jekyll and I reinstall all the dependencies, but it still says

Could not find blankslate- in any of the sources

I tried uninstall all gem packages and run gem install jekyll.
I also tried to install ruby-jekyll from AUR in Archlinux, and it still do not work.
Sorry for the complain, but I really feel depressed, it take me two hours to find a way to make jekyll works, but still failed.

It just always says some package cannot find, and after I install it, jekyll still complains.

Can anyone give me a kindly guide on Archlinux in my situation? Thanks in advance.

Hmm, I’m wondering if blankslate- is a dependency of jekyll or some other gem you are using in conjunction with it? Do you have any gems or themes listed in your _config.yml?

Oh, my _config.yml is out-of-date, it contains version number of JB:

JB :
    version : 0.3.0

I guess I should update the _config.yml file…
Many thanks!

1 Like

And about the Ruby/Jekyll/Archlinux… These two pages on the wiki always help me:


And I’ve noticed that there are a bunch of notes being added to the official docs about ruby/gems/bundler etc. Not sure if it helps, but my experience would probably be less painful if they were there where when jekyll and I first met. :slight_smile: