Error when running jekyll: Symbol not found: _ffi_type_double (LoadError)

After installing jekyll (v4.0.0 on Ruby v2.6.5 on macOS Mojave 10.14.6 with Xcode installed) when running any jekyll commands, like jekyll --version for instance, I receive an error: Symbol not found: _ffi_type_double (LoadError).

Found some ffi-related stuff on StackOverflow which did not help me. Therefore, I can’t use jekyll currently…any ideas on this?

Here’s the traceback:

MacBookPro-II:~ ms1$ jekyll
Traceback (most recent call last):
23: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/ruby_executable_hooks:24:in `<main>'
22: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/ruby_executable_hooks:24:in `eval'
21: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/jekyll:23:in `<main>'
20: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/jekyll:23:in `load'
19: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
18: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
17: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
16: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
15: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
14: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
13: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
12: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
11: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
10: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
 9: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 8: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 7: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
 6: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
 5: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc/native.rb:3:in `<top (required)>'
 4: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 3: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 2: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi.rb:4:in `<top (required)>'
 1: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require' /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require': cannot load such file -- 2.6/ffi_c (LoadError)
24: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/ruby_executable_hooks:24:in `<main>'
23: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/ruby_executable_hooks:24:in `eval'
22: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/jekyll:23:in `<main>'
21: from /Users/ms1/.rvm/gems/ruby-2.6.5/bin/jekyll:23:in `load'
20: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
19: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
18: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
17: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
16: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
15: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
14: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
13: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
12: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
11: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
10: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 9: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 8: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
 7: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
 6: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/sassc-2.2.1/lib/sassc/native.rb:3:in `<top (required)>'
 5: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 4: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require'
 3: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi.rb:3:in `<top (required)>'
 2: from /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi.rb:6:in `rescue in <top (required)>'
 1: from /Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in`require'/Users/ms1/.rvm/rubies/ruby-2.6.5/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:54:in `require':dlopen(/Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi_c.bundle, 9): Symbol not found: _ffi_type_double (LoadError)
Referenced from: /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi_c.bundle
Expected in: flat namespace
in /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi_c.bundle - /Users/ms1/.rvm/gems/ruby-2.6.5/gems/ffi-1.11.1/lib/ffi_c.bundle
MacBookPro-II:~ ms1$

Installing Mac OS X was the only solution. Now Jekyll is running again…