Jekyll fails on macOS Catalina

Hi,

I followed the steps here https://jekyllrb.com/docs/installation/macos/ and when I execute $ jekyll new test, I get the following error. Anyone knows what is going wrong?

Traceback (most recent call last):
    21: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `<main>'
    20: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `load'
    19: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
    18: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    17: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    16: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
    15: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    14: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    13: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
    12: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    11: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    10: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
     9: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
     8: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
     7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
     6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
     5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'
     4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'
     3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:11:in `<module:Native>'
     2: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'
     1: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'
/Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle, 0x0005): in '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle' MH_DYLIB is missing LC_ID_DYLIB (LoadError)
    22: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `<main>'
    21: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `load'
    20: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
    19: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    18: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    17: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
    16: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    15: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    14: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
    13: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    12: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
    11: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
    10: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
     9: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
     8: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
     7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
     6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'
     5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'
     4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:10:in `<module:Native>'
     3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:13:in `rescue in <module:Native>'
     2: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'
     1: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'
/Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle, 0x0005): in '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle' MH_DYLIB is missing LC_ID_DYLIB (LoadError)

I also tried the rbenv solution with no success:

$ rbenv install 2.6.3
Downloading openssl-1.1.1d.tar.gz...
-> https://dqw8nmjcqpjn7.cloudfront.net/1e3a91bc1f9dfce01af26026f856e064eab4c8ee0a8f457b5ae30b40b8b711f2
Installing openssl-1.1.1d...

BUILD FAILED (OS X 10.15.2 using ruby-build 20191225)

Inspect or clean up the working tree at /var/folders/z3/sdgfvqvd7zv1khlswdg298y80000gn/T/ruby-build.20200102162624.62189.DVNAHQ
Results logged to /var/folders/z3/sdgfvqvd7zv1khlswdg298y80000gn/T/ruby-build.20200102162624.62189.log

Last 10 log lines:
      _s_server_main in s_server.o
  "_verify_stateless_cookie_callback", referenced from:
      _s_server_main in s_server.o
  "_wait_for_async", referenced from:
      _s_client_main in s_client.o
      _sv_body in s_server.o
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[1]: *** [apps/openssl] Error 1
make: *** [all] Error 2
1 Like
19: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
18: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

it looks like you have ruby installed in 2 places (/Users and /Library), that usually causes issues.
Try uninstalling ruby and re-installing it.

@rdyar, I uninstalled ruby and I re-installed it, I still have an issue:

Traceback (most recent call last):
        21: from /usr/local/bin/jekyll:23:in `<main>'
        20: from /usr/local/bin/jekyll:23:in `load'
        19: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
        18: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        17: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        16: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
        15: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        14: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        13: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
        12: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        11: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        10: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
         9: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
         8: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
         7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
         6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
         5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'
         4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'
         3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:11:in `<module:Native>'
         2: from /usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'
         1: from /usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'
/usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle, 5): no suitable image found.  Did find: (LoadError)
     /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle: load commands not in a segment
     /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle: load commands not in a segment
        22: from /usr/local/bin/jekyll:23:in `<main>'
        21: from /usr/local/bin/jekyll:23:in `load'
        20: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'
        19: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        18: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        17: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'
        16: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        15: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        14: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'
        13: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        12: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
        11: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'
        10: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
         9: from /usr/local/lib/ruby/site_ruby/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'
         8: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'
         7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'
         6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'
         5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'
         4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:10:in `<module:Native>'
         3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:13:in `rescue in <module:Native>'
         2: from /usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'
         1: from /usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'
/usr/local/lib/ruby/gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle, 5): no suitable image found.  Did find: (LoadError)
     /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle: load commands not in a segment
     /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle: load commands not in a segment

it still looks like it is installed twice - once in usr and once in users.

Maybe uninstall and then check to see if you can get the version number to see if it is still installed in another place?

OK, but I don’t succeed to remove ruby (twice).
I did:

$ brew uninstall ruby
Uninstalling /usr/local/Cellar/ruby/2.6.5... (19,390 files, 31.5MB)

I still have 1 ruby:

$ whereis ruby
/usr/bin/ruby

What I can do to remove this one ?
Thank you @rdyar

maybe you can just use that version of ruby - install jekyll and see if it works.

I did

$ gem install --user-install bundler jekyll
Successfully installed bundler-2.1.3
Parsing documentation for bundler-2.1.3
Done installing documentation for bundler after 2 seconds
-------------------------------------------------------------------------------------
Jekyll 4.0 comes with some major changes, notably:

  * Our `link` tag now comes with the `relative_url` filter incorporated into it.
    You should no longer prepend `{{ site.baseurl }}` to `{% link foo.md %}`
    For further details: https://github.com/jekyll/jekyll/pull/6727

  * Our `post_url` tag now comes with the `relative_url` filter incorporated into it.
    You shouldn't prepend `{{ site.baseurl }}` to `{% post_url 2019-03-27-hello %}`
    For further details: https://github.com/jekyll/jekyll/pull/7589

  * Support for deprecated configuration options has been removed. We will no longer
    output a warning and gracefully assign their values to the newer counterparts
    internally.
-------------------------------------------------------------------------------------
Successfully installed jekyll-4.0.0
Parsing documentation for jekyll-4.0.0
Done installing documentation for jekyll after 0 seconds
2 gems installed

And

$ jekyll new test
**Traceback** (most recent call last):

21: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `<main>'

20: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `load'

19: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'

18: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

17: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

16: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'

15: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

14: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

13: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'

12: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

11: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

10: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'

9: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

8: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'

6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'

5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'

4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'

3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:11:in `<module:Native>'

2: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'

1: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'

/Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': **Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle, 0x0005): in '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/libsass.bundle' MH_DYLIB is missing LC_ID_DYLIB (** **LoadError** **)**

22: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `<main>'

21: from /Users/valery/.gem/ruby/2.6.0/bin/jekyll:23:in `load'

20: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/exe/jekyll:8:in `<top (required)>'

19: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

18: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

17: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-4.0.0/lib/jekyll.rb:206:in `<top (required)>'

16: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

15: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

14: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll-sass-converter.rb:4:in `<top (required)>'

13: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

12: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

11: from /Users/valery/.gem/ruby/2.6.0/gems/jekyll-sass-converter-2.0.1/lib/jekyll/converters/scss.rb:3:in `<top (required)>'

10: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

9: from /Library/Ruby/Site/2.6.0/rubygems/core_ext/kernel_require.rb:92:in `require'

8: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `<top (required)>'

7: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc.rb:31:in `require_relative'

6: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:5:in `<top (required)>'

5: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:6:in `<module:SassC>'

4: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:10:in `<module:Native>'

3: from /Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/lib/sassc/native.rb:13:in `rescue in <module:Native>'

2: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `ffi_lib'

1: from /Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:99:in `map'

/Library/Ruby/Gems/2.6.0/gems/ffi-1.11.3/lib/ffi/library.rb:145:in `block in ffi_lib': **Could not open library '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle': dlopen(/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle, 0x0005): in '/Users/valery/.gem/ruby/2.6.0/gems/sassc-2.2.1/ext/libsass.bundle' MH_DYLIB is missing LC_ID_DYLIB (** **LoadError** **)**

alright, maybe you have it installed 3 times. You got rid of one, now you have 2 left???

I am not much of a ruby person, not sure why that would happen. I think you are supposed to be able to manage which version of ruby you use somehow.

I finally found a solution here: https://github.com/sass/sassc-ruby/issues/146
I had to do this

gem uninstall sassc
gem install sassc --user-install
gem install --user-install sassc -- --disable-march-tune-native

Now it works :slight_smile:
I hope that will help other people, because it was a nightmare for me, I lost me several days with this issue.

1 Like