Can't update minima theme 2.5.0 to 3.0.0 [Newbie Here]

This is my repo for github pages.

I’ve cloned this into my local machine and trying to update the minima theme from 2.5.0 to 3.0.0.

Tried few things after googling for a while, but nothing seems to be working.

I’m a newbie here, please help.

Can you explain what you changed to try to update? I can only see your repo and there has been no push since last year, so locally what did you change? Your Gemfile and Gemfile.lock both still reference 2.5, 2.5.1 can you update those then push it to Github?

What is the error you get? Can you paste it here so we can see what isn’t working exactly?

Thanks @leatheresque

I’ve updated my Gemfile and Gemfile.lock then tried to run the usual commands in the terminal and getting these errors

tarif@tarif-ubuntu-mate:~/$ bundle install
Fetching gem metadata from
Could not find gem ‘minima (~> 3.0.0)’ in rubygems repository or installed locally.

The source contains the following gems matching ‘minima’:

  • minima-0.1.0
  • minima-1.0.0
  • minima-1.0.1
  • minima-1.1.0
  • minima-1.2.0
  • minima-2.0.0
  • minima-2.1.0
  • minima-2.1.1
  • minima-2.2.0
  • minima-2.2.1
  • minima-2.3.0
  • minima-2.4.0
  • minima-2.4.1
  • minima-2.5.0
  • minima-2.5.1
    tarif@tarif-ubuntu-mate:~/$ bundle exec jekyll serve
    Could not find gem ‘minima (~> 3.0.0)’ in locally installed gems.

The source contains the following gems matching ‘minima’:

  • minima-2.5.1
    Run bundle install to install missing gems.

Please let me know how to solve this

As of this writing, the latest published version of minima is 2.5.1. See the releases on the GitHub repo. Perhaps there is a version 3.0 and I am not aware of it, so we might ask @ashmaroli to chime in just to be sure.

Right now, you have a line in your Gemfile that looks like this:

gem "minima", "~> 2.5"

That line says “get me the latest minima theme, so long as it is greater than 2.5, and less than 3.x.x”. Technically, you could change that line to:

gem "minima", "> 2.5"

That way, if a 3.0 ever does come out and you run a bundle install (and perhaps a bundle update), you will get the latest and greatest version. That said, you are not guaranteed it will support GitHub Pages, which I believe you are using.

I recommend keeping your setting as it is. If you see a newer version of minima that I do not see, please share the link.

Finally, when you run bundle install, it updates the Gemfile.lock for you, so I do not recommend you update that file. Technically, you could delete the lock file, run bundle install or bundle update, and the lock file will be re-generated.

Hope this helps!


It is solved, you are using the current version :slight_smile:

1 Like

Thanks @leatheresque and @BillRaymond

You guys are real saviors… :saluting_face: