File to import not found or unreadable: minima

I think I have the problem described in jekyll work in local but not work github. File to import not found or unreadable: minima - Stack Overflow, except I am not testing my site locally. Locally I have a different site I am testing with in which I can customize the CSS but when I try to do the same thing in GitHub pages (see SamHobbsOrg/ I get the message as shown in the Stack Overflow question.

I do not understand the solutions and suggestions in the Stack Overflow question. When I try to use the bundle command it is not found. I am using Windows but I am using Eclipse instead of Visual Studio Code. When I try to use the bundle command in a console (terminal) window it says Could not locate Gemfile or .bundle/ directory. I correspondingly do not know how to issue the other commands shown there. I assume I can install something to get the bundle command to work; I probably need to modify my local repository so it works locally too. I am not sure it is worth doing that. It would be useful to be able to test locally.

I have also seen Noobie - Changing Font Variables - Help - Jekyll Talk and watched Bill’s video but I think the suggestion there is to convert the minima theme to a regular theme and I want to avoid that if possible.

I just want to make relatively small customizations of the CSS; the main thing I want to do is to undo (revert) some of the styling removed (the comment says reset) by minima. Is there a way to do that in GitHub pages and retain the minima theme?

It seems like you are asking a few questions here, so let’s work out the first one, which is why your GitHub Pages are not running locally (and why you are getting build errors on GitHub, but I don’t know if you noticed that :slight_smile: ).

The significant issue here is your site is not fully configured. I cloned your site, made a few changes, and even ran it through GitHub Pages, and the site runs fine.

  1. Your _config.yml file is not configured correctly. You need to have a baseurl and url, along with the mention of your theme. I wonder did you have this at some point and accidentally deleted it? Anyway, I used the config from a brand new Jekyll site and set it up for you, so you can copy and paste over what you have on the main branch right now:
# Welcome to Jekyll!
# This config file is meant for settings that affect your whole blog, values
# which you are expected to set up once and rarely edit after that. If you find
# yourself editing this file very often, consider using Jekyll's data files
# feature for the data you need to update frequently.
# For technical reasons, this file is *NOT* reloaded automatically when you use
# 'bundle exec jekyll serve'. If you change this file, please restart the server process.

# Site settings
# These are used to personalize your new site. If you look in the HTML files,
# you will see them accessed via {{ site.title }}, {{ }}, and so on.
# You can create any custom variable you would like, and they will be accessible
# in the templates via {{ site.myvariable }}.
title: Sam Hobbs's Web Site
description: >- # this means to ignore newlines until "baseurl:"
  My personal website.
baseurl: "/" # the subpath of your site, e.g. /blog
url: "" # the base hostname & protocol for your site, e.g.
twitter_username: jekyllrb
github_username:  jekyll

# Build settings
markdown: kramdown
theme: minima
  - jekyll-feed

# Exclude from processing.
# The following items will not be processed, by default. Create a custom list
# to override the default setting.
# exclude:
#   - Gemfile
#   - Gemfile.lock
#   - node_modules
#   - vendor/bundle/
#   - vendor/cache/
#   - vendor/gems/
#   - vendor/ruby/
  1. You do not have a gemfile at the root of your main branch. Create that file (no extension) and paste the following text in:
source ""

# Hello! This is where you manage which Jekyll version is used to run.
# When you want to use a different version, change it below, save the
# file and run `bundle install`. Run Jekyll with `bundle exec`, like so:
#     bundle exec jekyll serve
# This will help ensure the proper Jekyll version is running.
# Happy Jekylling!
gem "jekyll", "~> 3.9.0"

# This is the default theme for new Jekyll sites. You may change this to anything you like.
gem "minima", "~> 2.5.1"

# If you want to use GitHub Pages, remove the "gem "jekyll"" above and
# uncomment the line below. To upgrade, run `bundle update github-pages`.
# gem "github-pages", group: :jekyll_plugins

# If you have any plugins, put them here!
group :jekyll_plugins do
  gem "jekyll-feed", "~> 0.6"

# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
# and associated library.
install_if -> { RUBY_PLATFORM =~ %r!mingw|mswin|java! } do
  gem "tzinfo", "~> 1.2"
  gem "tzinfo-data"

# Performance-booster for watching directories on Windows
gem "wdm", "~> 0.1.0", :install_if => Gem.win_platform?

# kramdown v2 ships without the gfm parser by default. If you're using
# kramdown v1, comment out this line.
gem "kramdown-parser-gfm"

gem "webrick", "~> 1.7"

At this point, your website should build on GitHub Pages and you should be able to pull these changes down locally.

When you pull down locally for the first time, run the following commands for the first time:

bundle install
bundle update

Moving forward, keep your local and remote in sync and you should just have to type the following to view your site locally:

bundle exec jekyll serve --livereload

FYI, I am not a Windows user, so do not know if there are any other things you will have to do in order to get Ruby and Jekyll running, but it worked just fine on my Mac.

Thank you. It now works locally. In GitHub it builds but it seems to have lost all style.

Actually I was asking about the build error I quoted as the title of this, and the question in the Stackoverflow question. I could have been more clear; after posting I realized I spent so much time attempting to provide details that I might not have been clear about the main question.

Yes I did. I was asking about that.

I assume I need to use SamHobbsOrg instead of billraymond.

I originally created the (repository) site in GitHub using GitHub Pages and tried to follow instructions for specifying a theme. Perhaps I did not follow the instructions but that is how I got what I got. I think that GitHub Pages just did not create the gemfile. It also did not put much in the config.yml.

I had intended to convert my site to a GitHub Pages site using Jekyll with the minima theme but now I think I should convert it from the older version of ASP dot Net to ASP dot Net Core using Blazor.

Yes sorry, change to your site url not mine :slight_smile:

An easy mistake to make, I just wanted to ensure I understood.

I am not sure how I created the project but I have deleted the local and remote repositories a few times and I have tried to follow the instructions in Creating a GitHub Pages site with Jekyll - GitHub Docs as precisely as possible. The site works locally and it builds and deploys in GitHub but there is a problem. It is missing styling or something.

In the instructions I encountered the problem described in 2.2.0 causes LoadError · Issue #146 · sass/sassc-ruby. I was able to get the jekyll new command to work using a Windows Terminal (console) window instead of Git Bash window. I mention that in case it caused a problem I am unaware of.