Bundle ignoring config file

I am following the instructions provided on https://jekyllrb.com/tutorials/using-jekyll-with-bundler/ to setup a new Jekyll site with Bundler and git. I have done this plenty of times before without issue but this time Bundler is install all gems to my system gem folder instead of vendor/bundle

When I checked for a config file there was not one in the project folder but there was one in my user folder which had the following:

BUNDLE_SET: "--local path vendor/bundle"

Does the order of the config command need to be changed or something like that? Currently it is bundle config set --local path 'vendor/bundle' but this seems to be writing the entire command after set to the user config file instead of writing the value for the path parameter to the local config file.

What you are doing looks right. Check your bundle version. And run the command again.

Here is the syntax for Bundle 2 according to docs. https://bundler.io/v2.1/man/bundle-config.1.html

bundle config set --local <name> <value> 

And Bundle 1.16 https://bundler.io/v1.16/bundle_config.html

bundle config --local <name> <value>

Delete the file in the user folder.

I don’t use bundle to install anything at user level, just gem