Install jekyl under Ventura

I have installed ruby 2.7 with macports and I have issued
sudo gem install -n /usr/local/bin jekyll
gem install bundler
in a directory I have issued
bundle install
bundle add jekyll
bundle exec jekyll serve
and I get this error
Configuration file: none
I don’t think this is referring to the Gemfile, which is in place.
Can anyone advise please? The difference between this and my other mac is that I have installed ruby and jekyll with macports rather than homebrew.

I think it is referring to the config.yml file - is there one there? do you actually have a jekyll site in the folder you ran the command?

if not you need to make a new site (or download an existing one) using the jekyll new command followed by the name of the folder you want it to create the site in (?). Like: jekyll new my-awesome-site

Thank you for replying. I admit I don’t really know what I’m doing, but I have a directory on an older MAC (also upgraded to Ventura) in which that sequence brings my pages to localhost. In that directory there is no config.yml I have copied the directory to my new MAC and the same sequence leads to the error I’ve reported. I thought that the .yml .yaml file was only needed for when I build from GitLab where my pages are hosted. Tony.

the config file is just about the only required thing in a jekyll site - other than an index page? though normally there would be lots of other pages and directories.

If there is no config.yml file then you don’t have a jekyll site and jekyll won’t work.

.yml or yaml files are a common file type for data - like the config file in jekyll or a build script or data file of some sort. The .yml file is not exclusive to jekyll, it is just what jekyll uses for its config.

If your old cpu doesn’t have a config file but jekyll runs and opens the browser I would find that surprising.

Can you share the full output of the terminal when you run jekyll serve on the old computer? and maybe a list of what is in that folder?

I think that I am mostly just confused. I found that version 2.7 of ruby failed with an error on my old MAC and I am therefore running ruby 2.6 I am reluctant to share publicly the whole contents of my directory as I am trying to build a website that’s not for myself. But I did issue this sequence in the directory on my old MAC,
% find . -name *.yml -print
% find . -name *.yaml -print
% /usr/local/lib/ruby/gems/2.6.0/bin/bundle exec jekyll serve
Configuration file: none
Source: /Users/tony/Dropbox/tony/MyWWW/Sarah-strata
Destination: /Users/tony/Dropbox/tony/MyWWW/Sarah-strata/_site
Incremental build: disabled. Enable with --incremental
done in 0.205 seconds.
Auto-regeneration: enabled for ‘/Users/tony/Dropbox/tony/MyWWW/Sarah-strata’
Server address:
Server running… press ctrl-c to stop.

so I don’t appear to have a config.yml file and this does not seem to matter to jekyll. In fact since in both instances bundle reports “Configuration file: none” I’m wondering whether this is actually the source of my problem.

On my newer MAC macports threw an error from
sudo port install ruby26
so I am having to use ruby 2.7. The output from there is this:

% which bundler
% bundler -v
Bundler version 2.4.3
% ruby -v
ruby 2.7.7p221 […]
% gem -v
% bundle exec jekyll serve
Configuration file: none
Jekyll 4.3.1 Please append --trace to the serve command
for any additional information or backtrace.
Traceback (most recent call last):
34: from /opt/local/bin/bundle:23:in <main>' 33: from /opt/local/bin/bundle:23:in load’
32: from /Users/tony/gem/gems/bundler-2.4.3/exe/bundle:33:in <top (required)>' 31: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/friendly_errors.rb:117:in with_friendly_errors’
30: from /Users/tony/gem/gems/bundler-2.4.3/exe/bundle:45:in block in <top (required)>' 29: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli.rb:28:in start’
28: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/vendor/thor/lib/thor/base.rb:485:in start' 27: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli.rb:34:in dispatch’
26: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/vendor/thor/lib/thor.rb:392:in dispatch' 25: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/vendor/thor/lib/thor/invocation.rb:127:in invoke_command’
24: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/vendor/thor/lib/thor/command.rb:27:in run' 23: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli.rb:491:in exec’
22: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli/exec.rb:23:in run' 21: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli/exec.rb:58:in kernel_load’
20: from /Users/tony/gem/gems/bundler-2.4.3/lib/bundler/cli/exec.rb:58:in load' 19: from /Users/tony/gem/bin/jekyll:23:in <top (required)>’
18: from /Users/tony/gem/bin/jekyll:23:in load' 17: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/exe/jekyll:15:in <top (required)>’
16: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary.rb:21:in program' 15: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/program.rb:44:in go’
14: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in execute' 13: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in each’
12: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/mercenary-0.4.0/lib/mercenary/command.rb:221:in block in execute' 11: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/commands/serve.rb:86:in block (2 levels) in init_with_program’
10: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/command.rb:91:in process_with_graceful_fail' 9: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/command.rb:91:in each’
8: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/command.rb:91:in block in process_with_graceful_fail' 7: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/commands/build.rb:30:in process’
6: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/commands/build.rb:30:in new' 5: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/site.rb:35:in initialize’
4: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/site.rb:118:in reset' 3: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/cache.rb:37:in clear_if_config_changed’
2: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/cache.rb:82:in []' 1: from /opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/cache.rb:167:in load’
/opt/local/lib/ruby2.7/gems/2.7.0/gems/jekyll-4.3.1/lib/jekyll/cache.rb:167:in `load’: end of file reached (EOFError)

I think I have some options: I can look for a non macports ruby 2.6; I can try and make a config.yml file (at gitlab there is a tool to do this) but my older MAC doesn’t throw an error even though it is missing. I can change from macports to homebrew on my new MAC, but I personally find homebrew difficult and I prefer macports.

Thank you, rdyar, for your help. Tony

without seeing what is in the directory you are in it is hard to know what is going on.

I don’t need to see the content of the files, but can you show what folders and files are in it? is there a _site folder? is there an index file? any other files or folders?

On the old computer what do you see when it runs and opens the browser to localhost? an actual website? that works?

I would not be too worried about ruby versions - without a config file you are not going to get anywhere I don’t think. Though maybe it is running with some sort of defaults but I doubt it.

If I run jekyll serve on an emtpy folder it doesn’t really error and it creates an empty _site folder - I do get the same config file not found message. So I am wrong about the config file being required. If I have an actual jekyll site in the root but no config file then it errors when it tries to read something - probably looking for something set in the config file.

Where did the site you are working on come from?

Here is a directory listing:
% ll
total 176
-rw-r–r–@ 1 tony staff 4419 3 Jan 13:42 favicon-16x16.png
-rw-r–r–@ 1 tony staff 1162 3 Jan 13:42 safari-pinned-tab.svg
-rw-r–r–@ 1 tony staff 7406 3 Jan 13:42 favicon.ico
-rw-r–r–@ 1 tony staff 5287 3 Jan 13:42 apple-touch-icon.png
drwxr-xr-x@ 19 tony staff 608 3 Jan 13:42 Images
-rw-r–r–@ 1 tony staff 2279 3 Jan 13:42 sarah.css
-rw-r–r–@ 1 tony staff 287 3 Jan 13:42 site.webmanifest
drwxr-xr-x@ 16 tony staff 512 3 Jan 13:42 _site
-rw-r–r–@ 1 tony staff 266 3 Jan 13:42 Gemfile
-rw-r–r–@ 1 tony staff 136 3 Jan 13:42 index.html~
-rw-r–r–@ 1 tony staff 1755 3 Jan 13:42 Gemfile.lock
-rw-r–r–@ 1 tony staff 346 3 Jan 13:42 pickpic.js
-rw-r–r–@ 1 tony staff 275 3 Jan 13:42 Gemfile~
-rw-r–r–@ 1 tony staff 23 3 Jan 13:42 robots.txt
-rw-r–r–@ 1 tony staff 2603 3 Jan 13:42 mstile-150x150.png
-rw-r–r–@ 1 tony staff 5729 3 Jan 13:42 android-chrome-96x96.png
-rw-r–r–@ 1 tony staff 246 3 Jan 13:42 browserconfig.xml
drwxr-xr-x@ 3 tony staff 96 3 Jan 13:42 vendor
-rw-r–r–@ 1 tony staff 4653 3 Jan 13:42 favicon-32x32.png
-rw-r–r–@ 1 tony staff 1997 3 Jan 18:18 index.html

Yes, it produces a working website at]( on my old MAC

The error log on my new MAC looks like a bug to me. I’m thinking that I have probably incorrectly installed ruby and jekyll and there may be conflicting versions on the disc. It may be well to uninstall and start again. I know where to get ruby and that bundle and gem are part of the ruby distribution. Is jekyll also included in the ruby distribution? If not, where do I get it from. On my old MAC it was installled with homebrew, but macports doesn’t know about jekyll.

@tonypaxton Hello. Before you resort to uninstalling Ruby from your new system, try deleting the .jekyll-cache directory first, then run a bundle exec Jekyll build.
If it still errors out, paste the error here within a pair of triple backtics.

@ashmaroli that has fixed it! It also executes bundle exec jekyll serve correctly. Many thanks indeed to you and to @rdyar . I am truly relieved, and what a simple solution!! Tony