Jekyll ignoring destination in _config.yml since update, builds to "build" folder in source


#1

Howdy. I updated ruby to 2.4.1 jekyll to 3.4.3 and now when I do jekyll build, it’s no longer respecting my entry for destination: in the _config.yml file.

Now, instead of building to ~/www/ where it always has, it’s building to a build directory inside of root, the way it might if you didn’t specify a destination.

I’m stumped. Anybody?

# Build settings
permalinks: pretty
markdown: kramdown
paginate: 10
paginate_path: "page:num/"
gems:
  - jekyll-feed
  - jekyll-paginate
exclude:
  - Gemfile
  - Gemfile.lock

#destination
destination: ~/www/blog

#2

Looks like you need to change the root path of your destination, maybe it doesn’t accept the tilde anymore? https://jekyllrb.com/docs/usage/


#3

It seems to be working now but I’m afraid I’m not sure why! I hadn’t changed the path yet, only time had passed. :confused: