Installed new theme called: Cayman, the got a 404 page


#1

Installed a new theme called Cayman.
Changed all the front matter’s layout to default, cos that’s the only layout Cayman supports.

Here is the theme: https://github.com/pages-themes/cayman

Here is the error message I got:

➜  slowpacedcoding git:(gh-pages) ✗ bundle exec jekyll serve
Ignoring commonmarker-0.17.13 because its extensions are not built. Try: gem pristine commonmarker --version 0.17.13
Configuration file: /Users/zhouxiang/git repos/slowpacedcoding/_config.yml
Invalid theme folder: _includes
            Source: /Users/zhouxiang/git repos/slowpacedcoding
       Destination: /Users/zhouxiang/git repos/slowpacedcoding/_site
 Incremental build: disabled. Enable with --incremental
      Generating...
       Jekyll Feed: Generating feed for posts
                    done in 0.188 seconds.
 Auto-regeneration: enabled for '/Users/zhouxiang/git repos/slowpacedcoding'
    Server address: http://127.0.0.1:4000
  Server running... press ctrl-c to stop.
[2018-10-07 02:55:07] ERROR `/slowpacedcoding/' not found.


#2

maybe you don’t have an index/home page any more? looks like it is working to me - just that page doesn’t exist.

If you look at your site folder is there an index.html at the root?

posting a repo link is always best, hard to tell much with just screenshots.


#3

Your homepage is at http://127.0.0.1:4000/ or http://localhost:4000 and not at http://127.0.0.1:4000/slowpacedcoding/
If you want to “serve” at your site at http://127.0.0.1:4000/slowpacedcoding/, then your baseurl should be set to /slowpacedcoding