YAML Front Matter Defaults Not Taking Effect

I am trying to use front matter defaults by setting them in the _config.yml but they don’t seem to be taking effect for some reason. My formatting seems correct and I am following the examples given here.

Any idea what I am doing wrong? I am trying to set the default parameter live to false for all files in the my-report/ folder.

# Build settings
markdown: kramdown

  - jekyll-feed
  - jekyll-sitemap
  - jekyll-seo-tag
  - jekyll-paginate-v2

# Pagination Settings
  enabled: true
  per_page: 9
  permalink: '/page:num/'
  title: ' - page :num'
  limit: 0
  sort_field: 'post-priority'
  sort_reverse: false
  debug: true

# Front Matter Defaults
      path: "my-report"
      live: false

Found the issue, i just needed to manually stop Jekyll serve and restart it, the changes took effect as expected.