[Solved] Impossible to display pictures when site is deployed

Hello :slight_smile:

It’s my first post here :wink:

I’m not a developper, but I’ve handled to install, used and made a website with Jekyll (very informative).

When I’m in local, no probleme, everything works great.

But when I deployed it, I can’t see any pictures.

You can check it here https://mademoisellebulle.fr

The problem seems to be this : https://mademoisellebulle.fr/beaute-peau-eau-chaude-laver-visage/https//mademoisellebulle.fr/uploads/laver-visage-eau-chaude-froide/2-beaute-eau-eau-chaude-laver-visage-2.jpg

OK, I understand that this url… doesn’t exists. But why Jekyll does this ?

I guess it’s due to the theme but the problem is I have no clue to where to start to investigate.

So… I’m complelty lost :sweat_smile:

If anyone can help me, will be appreciated :smiley: :sweat_smile::wink:

Thanks a lot


Well… more I investigated, less I understand :sweat_smile:

What I see is : in the code, the url is exacts. The problem is on the “get” parts.

To be honest, I’m not yet able to understand what it’s implies…

:sunny: :sunny: :sunny:

The photo itself exists here: https://mademoisellebulle.fr/uploads/laver-visage-eau-chaude-froide/2-beaute-eau-eau-chaude-laver-visage-2.jpg

The problem is that the right image has been prepended with the domain and its path twice, that because the first time (I am talking of the second match from left to right) the protocol isn’t separated by the comma : from the domain. If you look better you have https//mademoiselle... in place of https://mademoiselle.... It means that the browser considers that address a relative path, in a subfolder of the current path, and prepend the path of the current page to it.

In brief, somewhere you generate that kind of address with the wrong protocol, look at the _config if you have https// in place of https:// or https in place of https:.

Also, somewhere in your post templates look if the URL is hardcoded or refers to the wrong variable.

I have found !

I’ve remembered that in the config.yml i’ve put url : https://mademoisellebulle.fr … and when I removed it… all works !

But… it’s not supposed to “works like this normally” ?



That depends on how URLs are generated inside the template, I remember a change in that sense when Jekyll switched to the 4th version, probably the template hasn’t been correctly updated?

Right, the gemfile defined jekyll at 3.9 :+1:

gem “jekyll”, “3.9” (was 3.6)

A Thing I also found strange…

I’ve tried to use the last version, but seems I’m obliged to use 3.X for “jekyll-paginate” to works… but I really don’t know why and I don’t investigate more on that point.

I start to have the sensation that the theme I used is in fact a little bit “old” no ?

One question more, cause I’m a complete newby on Jekyll. I understand how important to use the last version of a CMS like WordPress for example (for security purpose). Using the last version of Jekyll is “important” if your website runs without problem online ?



No, it’s not important to have the latest Jekyll version as long as your templates and plugins work correctly and fit your needs.

Being my theme self-developed I upgraded to the 4 only to take advantage of some small improvements like some grouping functions they introduced.

Thanks for your time :wink:

1 Like

You’re welcome! If you want to learn more about it, I recommend starting a dummy website to use only for tests and development, first the site and then a small theme, only putting the hands-on you will learn more.
Until you deploy uploading manually the _site content don’t have to worry about the plugins you can include in your project.

Thanks for your advices :slight_smile:

1 Like