Sass (actually SCSS) not compiling

Hello! This is my local structure:

Nevermind the desktop.ini files, I’m keeping everything in a Google Drive folder – don’t judge me, I’m a paranoid newbie.

On localhost it compiles properly – but only after a few minutes and/or when I edit some content from any page.

On live version (hosted on Netlify) it doesn’t compile at all – it keeps the original colors and typography from the Forty theme I’m using (I’m just trying to tweak the theme a little, like use the Merriweather font family and some gray-ish colors).

Can someone help me?

maybe cause you have 2 files named main.scss?

Yeah, but one of them is inside the _sass folder and the other one inside the assets/css folder. Does it make a difference?

I have no idea, but it does seem suspicious to me. you are calling a file named the same thing as the file calling it.

other than that without having a repo to look at it is hard to tell.

I think you were right, because it worked! As soon as I renamed one of the main.scss files, it finally worked. Perhaps this has something to do with the gem install of the theme. Maybe the jekyll build is trying to override my override (xD) when those file names are equal. But then again none of this matters because the sun is going to explode. I love you, friend!