Minimal mistakes - custom sidebar not showing

I cannot get my custom sidebar to show. In the I have

   nav: "test"

in the frontmatter, and in _data/naviation.yml

    - title: "Test"
        - title: "This is a test title"
          url: /

I have no defaults specified in _config.yml - shouldn’t this work?

is that your exact yaml? I think it may not be formatted correctly. Not sure that is the problem or not.
Also front matter only needs to be 3 dashes not 4

  - title: Test
      - title: This is a test title
        url: /

I didn’t copy it over correctly - it did have three dashes.

I tried your formatting, but it doesn’t help - in my various attempts I often had slightly different formattings (2 instead of 4 spaces, with or without quotation marks around title, …) and none of those seemed to matter, and if they mattered I received an error.

I forgot to mention that it works when I use the frontmatter chunk in the _config.yml defaults, but I don’t want to do it this way because I need to turn the sidebar off for specific pages, which I don’t think is supported by that approach.

Also, when I download the repo and add a custom sidebar like this it works, so somewhere along my customization something must have gone wrong, but I there are no leads to where…I was hoping that someone could point me to possible error sources.

Is this the filename you’re using? If it is there’s a typo and that could by it’s not working. You want _data/navigation.yml not _data/naviation.yml

Also if you share a public repo it’s much easier to troubleshoot what the issue is. Otherwise we’re just guessing.

no, navigation.yml is named correctly in the repo - that was another typo :frowning:

this is the repo, this is the homepage:

I inserted the yaml frontmatter on the “Research” page

On this “Research” page - you have several Markdown files that use the same permalink so they overwrite the file you added the sidebar to.

In the last 3 .md files you have permalink: /research/… remove that or make each of those something unique (e.g. permalink: /research/isopods/) so they don’t overwrite which has the same permalink, automatically assigned by Jekyll.

1 Like

I totally forgot to modify the permalinks. not doing this late after work would have saved me some headache…I tried a lot to debug this, but didn´t have a clue where to look. can´t something like this generate a warning msg? although I guess it’s not technically an error…

in an case: thank you for ending my pain…