Local site lost all styling since changed base url

I edited my _config.yml file and changed the baseurl in order to get my site working with GitHub pages. I also added the GitHub pages Gem.

Doing so I my site hosted on guthub pages lost all styling. Also now I have lost all styling locally too. I tried going back and getting rid of the baseurl in _config.yml file but no luck.

So now every time I run the bundle exec jekyll serve locally I am getting the below error and my website has no styling locally.

ERROR `/css/main.scss’ not found.

any suggestions?

Here’s the live link https://crobbo.github.io/web-design-site/


is the baseurl part of the path to the css in code? doesn’t look like it. Go look at where in your source you are linking to the css and you need to add the baseurl to that.

One way is like:

{{ 'css/style.css' | relative_url }}

Yes I have already done this. See my github here

I should clarify. I got this working locally with styling by doing what you said but Github pages still showing no styling.

sure there are no other errors stopping it from building? if you make a text change that shows up?

Are you using anything in the _sass folder? if not I would delete that.

It looks right, other than you are importing into main.scss the bootsrap stuff, could be that that is failing?

Fixed it. Really silly error i made. My baseurl didn’t match my GitHub repo name.

I changed baseurl to /web-design-site from /website-design-site

sorry for wasting your time!