Jekyll is giving me an error after updating Ubuntu to 22.04

Hi all,

Yesterday, I had a running system and I upgraded my OS to Ubuntu 22.04f(yes this was mistake number 1). Today when I try to run my jekyll site locally, which was working yesterday I get this error:

	bundle exec jekyll serve
	Configuration file: /home/matchday/dev/libero/main-website/_config.yml
	            Source: /home/matchday/dev/libero/main-website/app
	       Destination: /home/matchday/dev/libero/main-website/_site
	 Incremental build: disabled. Enable with --incremental
	      Generating... 
	       Jekyll Feed: Generating feed for posts
	                    ------------------------------------------------
	      Jekyll 4.2.2   Please append `--trace` to the `serve` command 
	                     for any additional information or backtrace. 
	                    ------------------------------------------------
	/home/matchday/gems/bundler/gems/jekyll-assets-056d2c88719e/lib/jekyll/assets/patches/writer.rb:53:in `after_hook': wrong number of arguments (given 2, expected 1; required keywords: asset, env) (ArgumentError)
		from /home/matchday/gems/bundler/gems/jekyll-assets-056d2c88719e/lib/jekyll/assets/patches/writer.rb:28:in `call'
		from /home/matchday/gems/gems/sprockets-4.0.3/lib/sprockets/manifest.rb:196:in `block (3 levels) in compile'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/safe_task_executor.rb:24:in `block in execute'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/synchronization/mutex_lockable_object.rb:47:in `block in synchronize'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/synchronization/mutex_lockable_object.rb:47:in `synchronize'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/synchronization/mutex_lockable_object.rb:47:in `synchronize'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/safe_task_executor.rb:22:in `execute'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/promise.rb:564:in `block in realize'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:352:in `run_task'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:343:in `block (3 levels) in create_worker'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:334:in `loop'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:334:in `block (2 levels) in create_worker'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:333:in `catch'
		from /home/matchday/gems/gems/concurrent-ruby-1.1.10/lib/concurrent-ruby/concurrent/executor/ruby_thread_pool_executor.rb:333:in `block in create_worker'

I went to look at the environment settings and see this:

ruby -v
ruby 3.0.2p107 (2021-07-07 revision 0db68f0233) [x86_64-linux-gnu]

bundle -v
Bundler version 2.3.12

jekyll -v
jekyll 4.2.2

Any suggestion or help would be appreciated as I’d rather not have to downgrade my system. If there’s more info I should provide or some docs I should read, please let me know

Since you posted your question there, I know that you are aware, so this is mainly for everybody else facing the same problem: It’s being discussed on StackOverflow.

Also, in case this forum is monitored by any jekyll developers: “This” (see link) is not a sustainable solution (at all), so I believe jekyll shoul just support Ruby >= 3.