Jekyll-import for blogger not working

I just created a new jekyll site on my computer and was trying to import my content from blogger to it and the import method says it has no idea what I’m trying to do.

I’ve followed the instructions on the importer site for blogger and installed the dependencies and installed jekyll-import and I have the XML file in the folder

When I run the import it says this.

jekyll import blogger --source blog-11-07-2023.xml --replace-internal-link --comments
jekyll 4.3.2 | Error:  Whoops, we can't understand your command.
jekyll 4.3.2 | Error:  invalid option: --replace-internal-link
jekyll 4.3.2 | Error:  Run your command again with the --help switch to see available options.
/home/tom/.rvm/gems/ruby-3.1.3/gems/mercenary-0.4.0/lib/mercenary/program.rb:33:in `go': invalid option: --replace-internal-link (OptionParser::InvalidOption)
	from /home/tom/.rvm/gems/ruby-3.1.3/gems/mercenary-0.4.0/lib/mercenary.rb:21:in `program'
	from /home/tom/.rvm/gems/ruby-3.1.3/gems/jekyll-4.3.2/exe/jekyll:15:in `<top (required)>'
	from /home/tom/.rvm/gems/ruby-3.1.3/bin/jekyll:25:in `load'
	from /home/tom/.rvm/gems/ruby-3.1.3/bin/jekyll:25:in `<main>'
	from /home/tom/.rvm/gems/ruby-3.1.3/bin/ruby_executable_hooks:22:in `eval'
	from /home/tom/.rvm/gems/ruby-3.1.3/bin/ruby_executable_hooks:22:in `<main>'

I tried running it with just the import source too and it tells me this

jekyll import blogger --source blog-11-07-2023.xml
You must install the 'jekyll-import' gem version > 0 to use the 'jekyll import' command. 

but jekyll-import is installed. I even uninstalled it and reinstalled it and it still gives me the same messages.

gem -v says I have 3.3.26 installed

Any idea why jekyll-import is doing this?