Jekyll Github Not Publishing

Hello all, i am facing 404 Error in this
I used a jekyll theme, but i think this components folder GitHub - arnavmehta7/Arnav_Blog in the respository is causing Issues, can anyone PLEASE help me and tell my Mistake.
I just started today

Note: I have even tried adding a theme

I tried something more and created another Repo and changed base_url in GitHub - arnavmehta7/Arnav_Mehta .yml file–> No results

I tried running your site locally and noticed you have a few issues with the setup.

Add the following like to your gemfile:

gem "jekyll-theme-slate"

It also looks like you need to update several items in your gemfile.lock. Rather than listing each one out individually, you can just copy/paste the following:

    addressable (2.8.0)
      public_suffix (>= 2.0.2, < 5.0)
    citrus (3.0.2)
    cloudcannon-jekyll-bookshop (2.2.2)
      dry-inflector (>= 0.1, < 1.0)
      jekyll (>= 3.7, < 5.0)
      node-runner-temp-fix-windows (>= 1.0, < 2.0)
      toml-rb (>= 2.0, < 3.0)
    colorator (1.1.0)
    concurrent-ruby (1.1.9)
    dry-inflector (0.2.1)
    em-websocket (0.5.3)
      eventmachine (>= 0.12.9)
      http_parser.rb (~> 0)
    eventmachine (1.2.7)
    ffi (1.15.5)
    forwardable-extended (2.6.0)
    http_parser.rb (0.8.0)
    i18n (1.10.0)
      concurrent-ruby (~> 1.0)
    jekyll (4.2.1)
      addressable (~> 2.4)
      colorator (~> 1.0)
      em-websocket (~> 0.5)
      i18n (~> 1.0)
      jekyll-sass-converter (~> 2.0)
      jekyll-watch (~> 2.0)
      kramdown (~> 2.3)
      kramdown-parser-gfm (~> 1.0)
      liquid (~> 4.0)
      mercenary (~> 0.4.0)
      pathutil (~> 0.9)
      rouge (~> 3.0)
      safe_yaml (~> 1.0)
      terminal-table (~> 2.0)
    jekyll-bookshop (2.2.2)
      dry-inflector (>= 0.1, < 1.0)
      jekyll (>= 3.7, < 5.0)
    jekyll-pagebreak (0.9.1)
      jekyll (>= 3.7, < 5.0)
    jekyll-sass-converter (2.1.0)
      sassc (> 2.0.1, < 3.0)
    jekyll-seo-tag (2.8.0)
      jekyll (>= 3.8, < 5.0)
    jekyll-sitemap (1.4.0)
      jekyll (>= 3.7, < 5.0)
    jekyll-tagging (1.1.0)
    jekyll-theme-slate (0.2.0)
      jekyll (> 3.5, < 5.0)
      jekyll-seo-tag (~> 2.0)
    jekyll-watch (2.2.1)
      listen (~> 3.0)
    kramdown (2.3.1)
    kramdown-parser-gfm (1.1.0)
      kramdown (~> 2.0)
    liquid (4.0.3)
    listen (3.7.1)
      rb-fsevent (~> 0.10, >= 0.10.3)
      rb-inotify (~> 0.9, >= 0.9.10)
    mercenary (0.4.0)
    node-runner-temp-fix-windows (1.0.1)
    nuggets (1.6.0)
    pathutil (0.16.2)
      forwardable-extended (~> 2.6)
    public_suffix (4.0.6)
    rb-fsevent (0.11.1)
    rb-inotify (0.10.1)
      ffi (~> 1.0)
    rexml (3.2.5)
    rouge (3.28.0)
    safe_yaml (1.0.5)
    sassc (2.4.0)
      ffi (~> 1.9)
    terminal-table (2.0.0)
      unicode-display_width (~> 1.1, >= 1.1.1)
    toml-rb (2.1.2)
      citrus (~> 3.0, > 3.0)
    unicode-display_width (1.8.0)


  cloudcannon-jekyll-bookshop (= 2.2.2)
  jekyll-bookshop (= 2.2.2)
  jekyll-pagebreak (~> 0.3)


At this point, I think your site is “Jekyll-ready”. However, there appear to be several issues related to something called bookshop and toml files.

Here is an example of one of many (many) lines that appear:

 Bookshop: ❌ Error Parsing Story: Permission denied - /var/folders/q1/23cldb1n44b_7b_6d9vk6hwh0000gn/T/node_runner20220216-32284-r4qwk6js
                    Permission denied - /var/folders/q1/23cldb1n44b_7b_6d9vk6hwh0000gn/T/node_runner20220216-32284-r4qwk6js

And here is the summary at the end:

          Bookshop: Had trouble reading 15 file(s), retrying
          Bookshop: ❌ Failed to read 15 file(s)
          Bookshop: ❌ Failed to read blog-card/blog-card.bookshop.toml
          Bookshop: ❌ Failed to read blog-section/blog-section.bookshop.toml
          Bookshop: ❌ Failed to read button/button.bookshop.toml
          Bookshop: ❌ Failed to read contact-form/contact-form.bookshop.toml
          Bookshop: ❌ Failed to read content/content.bookshop.toml
          Bookshop: ❌ Failed to read hero/hero.bookshop.toml
          Bookshop: ❌ Failed to read newsletter/newsletter.bookshop.toml
          Bookshop: ❌ Failed to read page-heading/page-heading.bookshop.toml
          Bookshop: ❌ Failed to read page-image/page-image.bookshop.toml
          Bookshop: ❌ Failed to read posts-list/posts-list.bookshop.toml
          Bookshop: ❌ Failed to read project-card/project-card.bookshop.toml
          Bookshop: ❌ Failed to read projects-list/projects-list.bookshop.toml
          Bookshop: ❌ Failed to read projects-section/projects-section.bookshop.toml
          Bookshop: ❌ Failed to read testimonial-card/testimonial-card.bookshop.toml
          Bookshop: ❌ Failed to read testimonials-section/testimonials-section.bookshop.toml
          Bookshop: ❌ Check your TOML files are valid.

At this point, I have a feeling this is no longer a Jekyll issue, but a theme or plugin issue. I am not familiar with TOML, but it appears to be similar to YAML. Jekyll supports YAML natively, so I am not sure why you would be using TOML files.

Maybe you can clarify what you are trying to accomplish in a bit more detail if my answer does not help?

I added the “jekyll-theme-slate” in Gemfile and The Required code in Gemlock file
But it is working correctly for me

Configuration file: /home/user/Desktop/CODE/Blog/V2/_config.yml
          Bookshop: Parsing Stories from /home/user/Desktop/CODE/Blog/V2/components/components
          Bookshop: 15 structures built in 1.0s ✅
            Source: /home/user/Desktop/CODE/Blog/V2
       Destination: /home/user/Desktop/CODE/Blog/V2/_site
 Incremental build: disabled. Enable with --incremental
          Bookshop: Bookshop site data generated
  Jekyll Pagebreak: Running in-place on destination files
Pagebreak: Found 3 pages with pagination
Pagebreak: Found 0 items on "components/components/posts-list/posts-list.jekyll.html"; Building 0 pages of size 6
thread 'main' panicked at 'called `Option::unwrap()` on a `None` value', src/
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace
  Jekyll Pagebreak: Done in 6 milliseconds
                    done in 0.702 seconds.
 Auto-regeneration: enabled for '/home/user/Desktop/CODE/Blog/V2'
    Server address:
  Server running... press ctrl-c to stop.

I faced no error in running, i think you are running with node, can you try the same with “bundle exec jekyll serve” ?

I think once I tried to deploy a simple html on but it wasn’t published . I wonder if there is any issue in naming of my github respository

So I am neither much expert, but I have figured out to know that TOML files just contain the variables which would be used in html files
Like in a description variable in a toml file if i change anything the same changes are reflected on the website, not much difference

Like if i edit this description_html variable the same results would be shown in website

UPDATE:- I tried to upload the same code on netlify and it’s working and its deployed, I don’t think its any issue with code

Um anyone
Any help would be appreciated

why is there a package.json file in that repo? github is not going to install any packages for you so if that is required it isn’t going to work.

If you are saying it works locally for you but fails on GH then that could be why.

Interesting, For me the steps to run is:-
Go to the folder with gemfile
run bundle exec jekyll server
Done , it runs.

I don’t feel the same because I tried deploying in netlify and it is working

P.S. Jekyll can be run with npm or gem, its choice

sure you can use npm with jekyll locally (or via netlify or codebuild or probably gh actions) if you install the things in the package.json file. All I am saying is that GH pages is not going to install anything that the package.json file asks for. So if that breaks the site then that is why GH doesn’t work.

Also in your gem file you are referencing gems that are not on GH’s safe list. If you use something other than what is listed on this page - Dependency versions | GitHub Pages GH pages won’t work. You can probably still use it with GH actions but I don’t use that so can’t help you.

GH pages is pretty locked down - if it is anything other than straight forward jekyll it won’t work for security reasons - they only allow a handful of plugins and that’s it.

Where did you get the bookshop things listed in the gemfile and package file? I’m guessing you don’t need them - I think you just got them with some site you cloned? Looks like that is some sort of CloudCannon thing - not sure what it does for anything. You might try asking them for support.

I must think thats the reason.

Oh no, Bookshop is important, it is a component-based library that provides pre-made components/themes like bootstrap.