Jekyll build not working, "plugins/_site/backtick_code_block.rb or one of its dependencies installed."

I was trying to build and test my website and the only problem it seems to be having is getting the dependencies for backtick_code_block.rb. I received this error in particular:
Dependency Error: Yikes! It looks like you don't have /home/noodles/ufsit-website/plugins/_site/backtick_code_block.rb or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem. The full error message from Ruby is: 'cannot load such file -- pygments

I tried to add to the Gemfile to install backtick_code_block.rb as well as update pygment_code and pygment gems in general, but when running bundle install I often get backtick_code_block.rb not found and so I don’t know how to resolve this dependency problem at all. I even tried googling for backtick_code_block.rb and it didn’t show up as a result or gem at all. Could this be a deprecated gem I could delete? Here’s my Rubygems environment if it helps:

  - RUBY VERSION: 2.6.5 (2019-10-01 patchlevel 114) [x86_64-linux]
  - INSTALLATION DIRECTORY: /root/.rvm/gems/ruby-2.6.5
  - USER INSTALLATION DIRECTORY: /root/.gem/ruby/2.6.0
  - RUBY EXECUTABLE: /root/.rvm/rubies/ruby-2.6.5/bin/ruby
  - GIT EXECUTABLE: /usr/bin/git
  - EXECUTABLE DIRECTORY: /root/.rvm/gems/ruby-2.6.5/bin
  - SPEC CACHE DIRECTORY: /root/.gem/specs
    - ruby
    - x86_64-linux
     - /root/.rvm/gems/ruby-2.6.5
     - /root/.rvm/rubies/ruby-2.6.5/lib/ruby/gems/2.6.0
     - :update_sources => true
     - :verbose => true
     - :backtrace => false
     - :bulk_threshold => 1000
     - /root/.rvm/gems/ruby-2.6.5/bin
     - /root/.rvm/gems/ruby-2.6.5@global/bin
     - /root/.rvm/rubies/ruby-2.6.5/bin
     - /home/noodles/.rvm/bin
     - /usr/local/sbin
     - /usr/local/bin
     - /usr/sbin
     - /usr/bin
     - /sbin
     - /bin
     - /usr/games
     - /usr/local/games
     - /snap/bin

is this an existing site? new site? what is the base for the site? jekyll new?

Kind of sounds like it is an old site? pygments in no longer recommended. Are you using it for a particular reason?

is there a link to the repo?

if you just make a new jekyll site does that work?

Something looks wrong with this path


The site directory should only have output and not ruby files.

I’d suggest a clean install of your repo in another directory. Or a jekyll new quickstart site

Or install a project jekyll from in your Gemfile. Then bundle install and bundle exec jekyl serve

Or upgrade global jekyll version

Also I see your gems listing is for root user paths. That could mean those aren’t readable by your user.

Perhaps you sent us the wrong output using sudo or did some unnecessary sudo installs when gem install --user GEM would have worked for installing bundler and jekyll

Thanks dude. That’s what I was thinking, of perhaps starting this website from scratch. I’m currently hosting the website right now from Gitlab under a .club domain. If I were to start over from scratch, would you know if the domain would still point to the website and deploy with the new files? Would I just need to keep the CNAME file?

Okay the code is on Gitlab. I don’t think you need to mess with the repo or domain. Or CNAME. On the server just clean the repo ie delete vendor directory of gems. And install Jekyll again using user flag above.

You need to be consistent in installing, running jekylk and listing gems as noodles, not as root. The output you sent doesn’t cover noodles gems yet the error arose in the noodles user’s website.

I’d highly recommend Github with a private repo if needed and continously deploy to Netlify, or use Github Pages. Then you don’t need to do any SSH or jekyll installing or rvm use or ruby debugging like here. Just commit, push and it deploys

You’ll be able to use your paid domain on netlify without paying netlify.

Oh wait you don’t need Github. Netlify can deploy and host for you using Gitlab