Jekyll Build causing error


#1

I’m trying to use Jekyll Build to generate my _site files but I’m stumbling into the following errors in terminal:

Not sure what steps I need to take to move forward. Ahhh.

Christians-MacBook-Pro:faculty christians$ jekyll build
WARN: Unresolved specs during Gem::Specification.reset:
      rb-fsevent (>= 0.9.4, ~> 0.9)
      rb-inotify (>= 0.9.7, ~> 0.9)
WARN: Clearing out unresolved specs.
Please report a bug if this causes problems.
/usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.15.1/lib/bundler/runtime.rb:317:in `check_for_activated_spec!': You have already activated liquid 4.0.0, but your Gemfile requires liquid 3.0.6. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)
	from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.15.1/lib/bundler/runtime.rb:32:in `block in setup'
	from /usr/local/Cellar/ruby/2.4.1_1/lib/ruby/2.4.0/forwardable.rb:229:in `each'
	from /usr/local/Cellar/ruby/2.4.1_1/lib/ruby/2.4.0/forwardable.rb:229:in `each'
	from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.15.1/lib/bundler/runtime.rb:27:in `map'
	from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.15.1/lib/bundler/runtime.rb:27:in `setup'
	from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.15.1/lib/bundler.rb:101:in `setup'
	from /usr/local/lib/ruby/gems/2.4.0/gems/jekyll-3.5.0/lib/jekyll/plugin_manager.rb:48:in `require_from_bundler'
	from /usr/local/lib/ruby/gems/2.4.0/gems/jekyll-3.5.0/exe/jekyll:9:in `<top (required)>'
	from /usr/local/bin/jekyll:22:in `load'
	from /usr/local/bin/jekyll:22:in `<main>'

#2

The solution may be in the error message above. Have you tried doing what it suggests by prepending the Jekyll commands with bundle exec?

bundle exec jekyll build
bundle exec jekyll serve

#4

Okay, I did the following in terminal:

bundle exec jekyll build

and it generated my _site directory. However, in Google’s Inspector, I’m receiving the following new error:

Failed to load resource: net::ERR_FILE_NOT_FOUND

Seems to not be locating my main.css file.

Sounds like that’s a whole different problem now. Any suggestions?


#6

Sounds like a path issue with that asset. You have a public repo to help with troubleshooting?


#7

Here’s my repo: https://github.com/christiantype/faculty

Thanks


#8

You don’t need to add the extension to your import statement.

- @import "normalize.css";
+ @import "normalize";

If the above raises any flags, rename normalize.css to normalize.scss


#9

Okay, I renamed normalize.css to normalize.scss and changed my @import statement to what you suggested.

I receive this in terminal now:

 Conversion error: Jekyll::Converters::Scss encountered an error while converting 'assets/main.scss':
                    File to import not found or unreadable: normalize. Load path: /Users/christians/Documents/faculty/_sass on line 3

#10

Ah yes, I forgot to mention… your new normalize.scss should be in _sass not in assets


#11

Hmm—I did that and my styles are still not generated in my _site directory.