Error in Terminal

When I run Jekyll Build, I receive the following error in Terminal:

Christians-MacBook-Pro:faculty christians$ jekyll build

WARN: Unresolved specs during Gem::Specification.reset:

jekyll-watch (~> 1.1)

rouge (< 3, >= 1.7)

rb-fsevent (>= 0.9.4, ~> 0.9)

rb-inotify (>= 0.9.7, ~> 0.9)

WARN: Clearing out unresolved specs.

Please report a bug if this causes problems.

/usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.3/lib/bundler/runtime.rb:313:in `check_for_activated_spec!': You have already activated liquid 4.0.0, but your Gemfile requires liquid 3.0.6. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)

from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.3/lib/bundler/runtime.rb:31:in `block in setup'

from /usr/local/Cellar/ruby/2.4.1_1/lib/ruby/2.4.0/forwardable.rb:229:in `each'

from /usr/local/Cellar/ruby/2.4.1_1/lib/ruby/2.4.0/forwardable.rb:229:in `each'

from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.3/lib/bundler/runtime.rb:26:in `map'

from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.3/lib/bundler/runtime.rb:26:in `setup'

from /usr/local/lib/ruby/gems/2.4.0/gems/bundler-1.16.3/lib/bundler.rb:107:in `setup'

from /usr/local/lib/ruby/gems/2.4.0/gems/jekyll-3.6.2/lib/jekyll/plugin_manager.rb:50:in `require_from_bundler'

from /usr/local/lib/ruby/gems/2.4.0/gems/jekyll-3.6.2/exe/jekyll:11:in `<top (required)>'

from /usr/local/bin/jekyll:22:in `load'

from /usr/local/bin/jekyll:22:in `<main>'

I see my _site folder update but then I get multiple errors in Console that read

Failed to load resource: net::ERR_FILE_NOT_FOUND

Somebody please help :frowning:

have you tried using bundler?

I think you need to do bundle exec jekyll serve

Bundler helps keep everything in sync as far as dependencies are concerned. If you read that entire error message it is telling you liquid is out of date and that prepending the jekyll command with bundle exec may help.

So when I do that, I no longer get any of the error messages.

This might be an unrelated problem to this thread but something I also noticed is that in Chrome’s Console, I receive this message Failed to load resource: net::ERR_FILE_NOT_FOUND and none of my stylesheets load.

I have to manually go into each .html file and update the path by removing a /

that is a different problem. So this issue is fixed by using bundler it sounds like.

If you have a css file not loading, then sure chrome will show that error as the path is wrong. Rather than manually edit the html file you need to figure out why the path is incorrect and just fix that.

I’d create a new post with that issue, and post the url you get that is incorrect and the code that creates the url, I’m sure it is a simple issue.