Jekyll 3.9.0 with GitHub Pages - Theme

Hello Users,

did you know a good working tutorial to use GitHub Pages with Jekyll 3.9.0?

My system

jekyll -v
jekyll 3.9.0

git --version
git version 2.30.2

ruby -v
ruby 2.7.4p191 (2021-07-07 revision a21a3b7d23) [x86_64-linux-gnu]

I want to create a Jekyll page on GiHub.

Which Free theme should be working with my system?

Thank you


Follow the GH tutorial!

Once you commit files changes the site will build and deploy. Its simple.

Also for a theme, go to repo settings, enable GH Pages and you will also see a theme chooser where you can preview about 10 themes which are standard for GH Pages.

Alternatively here are the gems in the environment and includes themes

Try this template

1 Like

Hello, i have many trouble with the Debian 11 default (see the first post) package.

jekyll new

## Running Jekyll as Non-Superuser (no sudo!)
## adding the following lines to the end of your .bashrc file:
export GEM_HOME=$HOME/gems
export PATH=$HOME/gems/bin:$PATH

sudo apt-get install ruby-dev ruby-full build-essential zlib1g-devel
gem install http_parser.rb -v '0.8.0' --source ''
gem install http_parser.rb
gem install webrick
bundle install

bundle exec jekyll serve --open-url --livereload  ## Error

## Message:
/gems/pathutil-0.16.2/lib/pathutil.rb:502: warning: Using the last argument as keyword parameters is deprecated
## Solution
gem install jekyll

jekyll new
## Error: undefined method `delegate_method_as' for Jekyll::Drops::CollectionDrop:Class (NoMethodError)
gem install jekyll jekyll-feed jekyll-gist jekyll-paginate jekyll-sass-converter jekyll-coffeescript

## Message:
have already activated eventmachine, but your Gemfile requires eventmachine 1.2.7. Prepending `bundle exec` to your command may solve this. (Gem::LoadError)
## Solution:
gem install eventmachine -v '1.2.7'

bundle exec jekyll serve --open-url --livereload ## it works fine

## news Test, delete folder
jekyll new
bundle exec jekyll serve --open-url --livereload  ## livereload doesn*t work
gem install eventmachine -v '1.2.7'
bundle update

git init
git add .
git commit -m "initial commit" 
git config --global ""                                                                      
git config --global "stevengghp" 

echo "#" >>
git init
git add
git commit -m "first commit"
git branch -M main
git remote add origin
git push -u origin main

I must solved many dependies.

My fist little success

now my Jekyll Release:

jekyll -v
jekyll 4.2.2

git clone

my second success

Chrome Browser with addon Wappalyzer:

Post-install message from sass:

Ruby Sass has reached end-of-life and should no longer be used.

* If you use Sass as a command-line tool, we recommend using Dart Sass, the new
  primary implementation:

* If you use Sass as a plug-in for a Ruby web framework, we recommend using the
  sassc gem:

* For more details, please refer to the Sass blog:

Ruby Sass has reached end-of-life and should no longer be used.

Did you have newer demo repositories?

I think isn’t a good idea to use only Debian 11 Bullseye sources.

I set this thread at solved for me.

Thank’s all.