Index.html showing nothing one line of text

I had no problems when I used a jekyll server to check my repo, except the avatar wasnt loading. So, i thought I should just deploy it to Github and when I opened my site, it shown completely blank except the content of index.html. The Github Actions show no error luckily after some tries when it used to show errors, but I fixed em. Now i dont know what to do.

XPhantom Repo

I think the problem is that you have a .nojekyll file, which causes Github to directly publish the repo, rather than build it with Jekyll.

So I guess I should delete it?

Edit: I deleted it, but still continues…

it still not fixed, idk what to do now

the line of text showing is the front matter so the index.html file is not being processed for some reason.

maybe remove the # Index Page line from the front matter, it might not like the #? though I would think it would error.

Have you tried running locally?

and you’re sure there is no error when it builds?

I’d add another page like in the root and just put the front matter with the layout in there and then see if that page works.

Yes, locally it works. But, for some reason when I open in the website, it just shows that damn text. Also, ill try what u did. And, it always say Actions Succesfull except i get some Dependency error or something…

Well,i get these errors:

  • in Jekyll CI / Build : fatal: detected dubious ownership in repository at '/srv/jekyll'
  • in Jekyll Deploy / build_and_deploy :
  #7 14.30 ERROR:  Error installing bundler:
  #7 14.30 	The last version of bundler (>= 0) to support your Ruby & RubyGems was 2.4.22. Try installing it with `gem install bundler -v 2.4.22`
  #7 14.30 	bundler requires Ruby version >= 3.0.0. The current ruby version is
  #7 ERROR: process "/bin/sh -c gem install bundler" did not complete successfully: exit code: 1

there is a lot going on in that repo, not sure if you need it - maybe it is part of the themes build process? and that is screwing up your build?

Is this a new site? if so check to see that you are using the theme properly.

It is new, how am I supposed to check the theme if its running properly? i dont understand much…

unfortunately I am not familiar with that theme and in looking at it for a bit it isn’t clear to me how to get the simplest version of it running - it looks like it has a lot of dependencies. Most themes I see are just css in some layouts/includes and it is easy to use.

It looks to me like you forked the main project, and in there is all kinds of node stuff that is needed in addition to jekyll. I can’t tell if you need it or not or if it is just in the way.

Your last error seems to say that the wrong version of ruby is installed when it runs the action? this could be that the action is trying to use an out of date docker instance? not really sure on this.

You might try asking questions on the chripy repo and maybe they can help.

I forked jekyll-theme-chirpy and used it rather than the template chirpy-starter.