Failing on the last step of the Jekyll Quickstart

I’ve followed the installation as outlined on the Quickstart page:

https://jekyllrb.com/docs/

After getting the path correctly set up (my first error encounter), things are failing at the last step (#5):

bundle exec jekyll serve

See the attached image for the result I get from this command. Note that it is also followed by a ton of “Control frame information” as well as “Ruby level backtrace information” and “Other runtime information”.

Any thoughts on this are welcome.

Thanks.

what happens if you just do jekyll serve?

that image doesn’t have a lot of info, more useful if you copy and paste the whole thing in here.

Are you on a mac or pc? using the default site or a repo?

Same result if I do jekyll serve.

On MacOS 11.5.1 (Big Sur).

Just trying to serve the default blog.

The whole resulting crash results are too long to post inline here. I’m attaching a longer image of the first part of the result.

Thanks.

not sure there is a limit to what you can post, that is certainly not too long to post as text. The advantage of posting the text is it is easy to copy parts of it and google it which is the best way to actually figure it out.

Like I would google that first line about ffi and the [Bug] bus error or whatever that says.

Thanks. I did get a message that the post with all the text was too long.

BUT…your suggestion of googling about ffi resulted in finding a fix. Apparently, there’s some stuff going on with the M1 Macs. I had to do this to make it work:

gem install --user-install ffi – --enable-libffi-alloc

Thanks for your help.

1 Like

This is still an issue on M1 Macs, using the latest version of macOS (Monterey 12.2).
The comment above works (as mentioned here), but it is mistyped.

The correct command is:

gem install --user-install ffi -- --enable-libffi-alloc
1 Like