Error: .md file not found


I’m a Jekyll newbie using minimal mistakes theme and getting an error:

`/_pages/’ not found.

From my file front matter:
url: “_pages/”

From the _config.yml file:

Reading Files


  • .htaccess
  • _pages

permalink: /product-photos/

Any suggestions greatly appreciated!



There’s not enough info for me to see where the problem is. So move your setup to a passing state. Then you can make one change at a time to your ideal state and then you’ll know that is the thing causing the problem. Some ideas below.

Have a look in your local _site directory to see if your product page got created. Then you know it was included. You might have to clean out your to not cause an error so you can get as a passing build.

Your config setup for include looks correct.

Can you try put your page in the root first and see if that works? Then move it to _pages later.

Can you share the name of your username and repo name e.g. abc/def or the repo URL.

The problem might be none of the things above mentioned but specially URL.

What is the point if the url param in your homepage? I can’t see the rest of the frontmatter but setting a single url to point to another page seems weird. Also, page.url is already a property set by Jekyll so you should not override it.

What are you trying to achieve? Add a link to the product page in the body of homepage, or navbar? Can you provide any links to docs for the theme which show how and why the URL field is used?

Can you get a demo of the theme with light content to work? Like in a separate repo.

You can also call your directory pages with no underscore.

Hi Michael,

My github userid is jimtompkins but I’m just working locally at the moment.

The file does not show up in my _site directory.

I don’t get any build errors, just an error when I click on the button to take me to the file.

I’m really just trying to have a link on one page to another one. I found an example that used the url keyword so I stayed with that.

I tried removing the underscore in the folder name but that didn’t work.

I tried moving it up out of the _pages subfolder but that didn’t work.

Thanks for your help,


1 Like

I don’t use that theme but it seems odd to have a url with a .md extension as that file will never exist.

Where did you see the pattern url: “_pages/”? is that something the theme supports? or just something you thought should work?

1 Like

I can’t remember… I might just be something that I thought should work…


I got it working by:

  1. changing the code to:
    url: /product-photos/
  2. moving files up out of _pages subfolder

I saw the URL syntax here:

Thanks for all of the suggestions!


Thanks that link makes sense.

Make sure to share the whole YAML next time, to show url is in a list.