Custom Domain name GH Pages Issues

I’ve encountered an issue where the images load fine but the page is broken with no basic scrolling and the page is not 100% transferred to fit the device.

Should I try CNAME? I’ll try again tomorrow anyway, if someone knows how to get us live that would make a whole load of difference.

I have my config set as
baseurl: “” # the subpath of your site, e.g. /blog
url: “” # the base hostname & protocol for your site, e.g.

(I have tried
I have also tried http://

  • for URL: )

It is not clear (to me at least) how the broken page and scrolling is related to the custom domain name. Probably it will help if you at least tell us if the page(s) work in If the problem is the same without the custom domain name then it is not caused by the custom domain name.

Since you are asking about setting up the custom domain name, perhaps the problem that you are having is that you are not seeing the GitHub version.

I have not configured my GitHub Pages site with a custom domain name but I am very close to being ready to do that. I have configured other domain names using a variety of hosts and registrars.

Looking at the documentation, are you using a (using their terminology) “www subdomain”, “Custom subdomain” or “Apex domain”?

Note that CNAME typically refers to records but GitHub is also using CNAME for files, so it is confusing to say CNAME without qualification. The documentation also says to create a CNAME record in your DNS provider so please be clear about where you are creating the CNAME record.

Since I do not yet have experience with custom domain names for GitHub Pages, I cannot help more. Configuration of DNS for GitHub Pages seems to be different from most hosts.

Please study the documentation and be sure to follow it precisely. And I totally understand how frustrating and confusing that can be. Since it is very complicated, when seeking assistance, you need to be clear about what you have done and what results you are getting and not getting.

Since I intend to configure a custom domain name for my GitHub Pages site, I did some research. The following seem to all provide a much simpler procedure. (I have three to suggest but as a beginner to this site I am allowed to provide only 2)

The third article is Linking A Custom Domain To Github Pages.

Note that if those do not work then the problem might be that in desperation you have (like me) done something causing the problem and the solution is to undo that something and the only way someone else knows what it is that you need to undo is if you tell us what you have done.

it looks mostly ok to me - though I see some JS errors in the console.

The custom domain works fine though, I think you are just having some sort of JS issues.

You aren’t giving much detail on what is actually wrong - like a specific page and description of what to look for would be helpful. Seems to scroll ok to me and I tried as a few different device simulations and it seemed ok.


Thanks for the reply.

The page works perfectly when I remove the link to my domain. When I change the baseurl the page works better, but the typical issue is that none of the CSS loads. But at least people can scroll and read the homepage.

There is an issue probably with JS however I have not set up the page in a sequenced order, I just did what came to me; Change the URL to the custom domain name, for example, as well as make records to the GitHub IPs with www and the root domain.

I could revert to GitHub io and find no issues. There would be no white boarder around the homepage which indicated CSS to me but since scrolling isn’t working it’s as if the page does not recognize the HTML properly, it’s almost like a printed page.

I have little to no clue what I’m actually doing but I’m enjoying testing it all. Sorry if I’m not very informative, however I actually used inspect element to diagnose my previous issues. This issue however seems to be something backend because the console does not register any issues as you’ve mentioned.

This is why I mentioned CNAME because if I can place the right file in the repo I thought it would make it run better at least - but I could be very wrong. To elebatorate for Sam, I have not registered a CNAME and in fact I found that part of the GHPages tutorial very confusing.

In case I wasn’t much help a second time, here’s the Demo to the theme I’m trying to use.

Hey guys really sorry, everything is fine.

There was a security issue, from the network provider and it made the page inaccessable because it thought it was a phishing site. Is there anyway to get a certificate of safety or something?