Auto-regeneration site won't build


#1

i am trying to learn how to use collections so i had done some work with the config file. now when i try to serve the site from terminal it shows:

Incremental build: disabled. Enable with --incremental
Generating…
done in 0.634 seconds.
Auto-regeneration: disabled. Use --watch to enable.

if I run it with --watch nothing gets loaded to localhost:4000. the only thing that might’ve happened while I was working in this session is I had cloned the jekyll docs folder on github to try to take a look at how it uses collections, and i ran the rake install on that which might’ve added a gem to my system.


#2

Running a rake task in the cloned Jekyll repository does not mess anything up.
The output in your post above done in 0.634 seconds. means that Jekyll did not encounter any fatal errors along the way.

But the Auto-regeneration: disabled. Use --watch to enable. message is telling me that you ran jekyll build instead of jekyll serve
jekyll build will not mount your site to localhost.


Walkthrough the following to serve the official Jekyll docs site on your browser:

  • cd into the docs folder of the cloned repository.
  • run bundle install to install any missing plugins.
  • run bundle exec jekyll serve
  • wait for the done in ... seconds message
  • wait for Jekyll to mount its local server (till you see Server running... press ctrl-c to stop.)
  • open your browser and go to http://localhost:4000

Note: Auto-regeneration is enabled by default when your run jekyll serve, so there’s no need of the --watch switch.


#3

oh wow you are right, i was typing in build instead of serve. i must’ve had a bad case of tunnel vision on that one! thanks.