Posts not getting processed at all


#1

Hi there,

I’m pretty desperate at the moment. I tried everything I can, however, posts under _posts aren’t getting processed at all and I really don’t know why anymore. I checked the filename, the correct date (not in the future), set published to true, nothing helps. Maybe someone of you may has a tip for me, I already ran out of ideas.

_config.yaml:

# Site settings
# These are used to personalize your new site. If you look in the HTML files,
# you will see them accessed via {{ site.title }}, {{ site.email }}, and so on.
# You can create any custom variable you would like, and they will be accessible
# in the templates via {{ site.myvariable }}.
title: My title
email: [email protected]
description: >- # this means to ignore newlines until "baseurl:"
  my description
baseurl: "" # the subpath of your site, e.g. /blog
url: "" # the base hostname & protocol for your site, e.g. http://example.com
# twitter_username: jekyllrb
# github_username:  jekyll
lang:   de

# Path settings
source:          .
destination:     ./_site
collections_dir: .
plugins_dir:     _plugins
layouts_dir:     _layouts
data_dir:        _data
includes_dir:    _includes
posts_dir: _posts


# Handling reading
encoding:             "utf-8"
markdown_ext:         "markdown,mkdown,mkdn,mkd,md"
exclude:
    [
        "bower_components/",
        "scss/",
        "config.codekit3",
        "Gemfile",
        "Gemfile.lock",
        "bower.json",
        "*.gemspec",
        "css/"
    ]

# Plugins
plugins:
  [
    "jekyll-feed"
    ]

# Conversion
markdown:    kramdown
highlighter: rouge
lsi:         false
excerpt_separator: "\n\n"
incremental: false

# Serving
detach:  false
port:    4000
host:    127.0.0.1
baseurl: "" # does not include hostname
show_dir_listing: false

# Outputting
permalink:     pretty
#paginate_path: /page:num
#paginate:   10
timezone:      'Europe/Vienna'

quiet:    false
verbose:  false

# Exclude from processing.
# The following items will not be processed, by default. Create a custom list
# to override the default setting.
# exclude:
#   - Gemfile
#   - Gemfile.lock
#   - node_modules
#   - vendor/bundle/
#   - vendor/cache/
#   - vendor/gems/
#   - vendor/ruby/

defaults:
    -
        scope:
            path: ""
        values:
            layout: "default"

liquid:
  error_mode: warn

# Markdown Processors
rdiscount:
  extensions: []

redcarpet:
  extensions: []

kramdown:
  auto_ids:       true
  entity_output:  as_char
  toc_levels:     1..6
  smart_quotes:   lsquo,rsquo,ldquo,rdquo
  input:          GFM
  hard_wrap:      false
  footnote_nr:    1
  show_warnings:  false

sass:
    sass_dir:   _sass
    style:      compact

Directory listing:

ll _posts
total 8
drwxr-xr-x   3 thomas  staff   96 27 Feb 22:45 ./
drwxr-xr-x  25 thomas  staff  800 27 Feb 23:22 ../
-rw-r--r--   1 thomas  staff  142 27 Feb 23:30 2018-02-27-my-very-first-post.md

Content of the post:

# cat _posts/2018-02-27-my-very-first-post.md 
---
layout: post
title: Folge 1 - Lust und Frust
date: 2018-02-26 20:23
published: true
category: something
---

Dies ist mein erster Beitrag

And finally the output of the startup the webserver:

# bundle exec jekyll server --livereload --verbose
  Logging at level: debug
Configuration file: /Users/thomas/CloudStation/Krieg & Frieden/webseite/entwurf/_config.yml
  Logging at level: debug
         Requiring: jekyll-feed
            Source: .
       Destination: ./_site
 Incremental build: disabled. Enable with --incremental
      Generating... 
       EntryFilter: excluded /config.codekit3
       EntryFilter: excluded /bower.json
       EntryFilter: excluded /Gemfile
       EntryFilter: excluded /Gemfile.lock
       EntryFilter: excluded /css/kuf.css
       EntryFilter: excluded /css/kuf.css.map
       EntryFilter: excluded /bower_components/bulma-pageloader
       EntryFilter: excluded /bower_components/bulma-slider
       EntryFilter: excluded /bower_components/bulma-badge
       EntryFilter: excluded /bower_components/bulma-calendar
       EntryFilter: excluded /bower_components/bulma-iconpicker
       EntryFilter: excluded /bower_components/bulma-tooltip
       EntryFilter: excluded /bower_components/bulma-pricingtable
       EntryFilter: excluded /bower_components/bulma-carousel
       EntryFilter: excluded /bower_components/bulma-steps
       EntryFilter: excluded /bower_components/bulma-checkradio
       EntryFilter: excluded /bower_components/bulma
       EntryFilter: excluded /bower_components/bulma-accordion
       EntryFilter: excluded /bower_components/bulma-tagsinput
       EntryFilter: excluded /bower_components/bulma-extensions
       EntryFilter: excluded /bower_components/bulma-quickview
       EntryFilter: excluded /bower_components/bulma-switch
       EntryFilter: excluded /bower_components/bulma-timeline
       EntryFilter: excluded /bower_components/bulma-divider
       EntryFilter: excluded /bower_components/bulma-ribbon
        Generating: JekyllFeed::Generator finished in 0.000708 seconds.
         Rendering: 404.html
  Pre-Render Hooks: 404.html
  Rendering Liquid: 404.html
  Rendering Markup: 404.html
  Rendering Layout: 404.html
         Rendering: about.md
  Pre-Render Hooks: about.md
  Rendering Liquid: about.md
  Rendering Markup: about.md
  Rendering Layout: about.md
         Rendering: impressum.md
  Pre-Render Hooks: impressum.md
  Rendering Liquid: impressum.md
  Rendering Markup: impressum.md
  Rendering Layout: impressum.md
         Rendering: index.md
  Pre-Render Hooks: index.md
  Rendering Liquid: index.md
  Rendering Markup: index.md
  Rendering Layout: index.md
         Rendering: assets/kuf.scss
  Pre-Render Hooks: assets/kuf.scss
  Rendering Liquid: assets/kuf.scss
  Rendering Markup: assets/kuf.scss
         Rendering: feed.xml
  Pre-Render Hooks: feed.xml
  Rendering Liquid: feed.xml
  Rendering Markup: feed.xml
  Rendering Layout: feed.xml
                    done in 1.03 seconds.
         Requiring: jekyll-watch
           Watcher: Ignoring (?-mix:_config\.yml)
           Watcher: Ignoring (?-mix:_site)
           Watcher: Ignoring (?-mix:bower_components)
           Watcher: Ignoring (?-mix:config\.codekit3)
           Watcher: Ignoring (?-mix:Gemfile)
           Watcher: Ignoring (?-mix:Gemfile\.lock)
           Watcher: Ignoring (?-mix:bower\.json)
           Watcher: Ignoring (?-mix:css)
 Auto-regeneration: enabled for '.'
LiveReload address: http://127.0.0.1:35729
[2018-02-27 23:37:11] INFO  WEBrick 1.4.2
[2018-02-27 23:37:11] INFO  ruby 2.5.0 (2017-12-25) [x86_64-darwin15]
[2018-02-27 23:37:11] DEBUG WEBrick::HTTPServlet::FileHandler is mounted on /.
[2018-02-27 23:37:11] DEBUG unmount .
[2018-02-27 23:37:11] DEBUG Jekyll::Commands::Serve::Servlet is mounted on .
    Server address: http://127.0.0.1:4000/
[2018-02-27 23:37:11] INFO  WEBrick::HTTPServer#start: pid=13234 port=4000
  Server running... press ctrl-c to stop.
        LiveReload: Browser connected

What really pussled my is the fact, that Jekyll even does not lookup in _posts, only whenever I change something in my post and save it, then the server recognizes a change to a file:

 Regenerating: 1 file(s) changed at 2018-02-27 23:39:51
                _posts/2018-02-27-my-very-first-post.md

… but it does not create something in _site:

drwxr-xr-x  11 thomas  staff   352 27 Feb 23:37 ./
drwxr-xr-x  25 thomas  staff   800 27 Feb 23:22 ../
drwxr-xr-x   3 thomas  staff    96 27 Feb 23:21 404/
drwxr-xr-x   3 thomas  staff    96 27 Feb 23:21 about/
drwxr-xr-x   3 thomas  staff    96 27 Feb 23:21 assets/
-rw-r--r--   1 thomas  staff  1125 27 Feb 23:39 feed.xml
drwxr-xr-x   7 thomas  staff   224 27 Feb 23:37 img/
drwxr-xr-x   3 thomas  staff    96 27 Feb 23:21 impressum/
-rw-r--r--   1 thomas  staff  1368 27 Feb 23:39 index.html
-rw-r--r--   1 thomas  staff  1186 25 Feb 22:47 page.html

Any ideas, any hints?

Many, many thanks in advance, regards, Thomas


#2

maybe remove posts_dir: _posts from the config? it is a default setting and shouldn’t need to be specified.

what happens if you just build the site - bundle exec jekyll build? does it output them now?


#3

Hi,

adding posts_dir was just a desperate attempt to point Jekyll to that directy, it actually has no effect. I also removed everything from _site and reran bundle exec jekyll serve which actually builds up _site from scratch again - no success so far. All posts are still being ignored for no obvious reason.

I think I’m going to start over with a clean directory.

Regards, Thomas


#4

@mosesontheweb Any change with starting over a clean directory?

A missing information detail you left out was your Gemfile… Plugins loaded via :jekyll_plugins will not be mentioned in the --verbose output and one of them could be messing with Jekyll’s PostReader